Page 1 of 9 123 ... LastLast
Results 1 to 10 of 82
  1. #1

    2011 300x 155 hrs down 250 rpm 3mph and some boost

    2011 300x 155 hrs, wont rev past 7,500, barely cracks 67mph. Ski usually hits 7,800 and 71mph and just rounds the corner on the boost gauge. Removed plugs, kinda white, looked lean, put in new plugs and seafoam, fresh tank of 93. By the end of the day i may have picked up 50 rpm. Disconnected the scom and ski ran same until f1 code came on. So essentially ski isnt even making enough rpms to reach the scom override, boost is around 13 on the gauge usually hits 16. Any suggestions would be appreciated . seems to run great except for the missing 300 rpms and 3 lbs of boost.
    Last edited by Chris288; 06-15-2015 at 01:23 PM.


  2. #2
    Fat Man, Little Boat Region8Ultra250X's Avatar
    Join Date
    Jun 2007
    Location
    Jersey
    Posts
    5,661
    +1
    189
    have you check the usual suspects? BOV, Belt Tension, loose clamps on couplers?

  3. +1 by:


  4. #3
    Banned User
    Join Date
    Aug 2009
    Location
    Discovery Bay, CA
    Posts
    3,048
    +1
    337
    Belt or tensioner, if the tensioner is no good replace the belt too

  5. #4
    My bad, forgot to mention i went around and tightened every hose clamp, and bov.

  6. #5
    "just sayin".. jetdave56's Avatar
    Join Date
    Nov 2008
    Location
    JERSEY SHORE
    Posts
    4,522
    +1
    626
    One other usual suspect ,dirty IC..

  7. #6
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    doubt its the i/c unless you have never ever cleaned it.


    ive given this tip many times but nobody listens!!!
    have you measured the fuelpump output at 3sec prime at 155hrs and i bet the filter is retricted.

  8. #7
    Okay, stupid question, where is the fuel filter located ? I definitely think its fuel related as the plugs were chalky

  9. #8
    "just sayin".. jetdave56's Avatar
    Join Date
    Nov 2008
    Location
    JERSEY SHORE
    Posts
    4,522
    +1
    626
    The fuel filter itself I believe cannot be cleaned as it's built into the fuel pump but there is a fuel screen to catch debri on the bottom of the fuel pump so your gonna have to pull the pump , it is part of periodic maintenance and with your hrs (155) might be a good time to examine and clean..

  10. #9
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    totally off the ball.. the filter can be cleaned it sits above the fuelpump, the pick up screen DOES NOT filter fine enough.

    to the op drop the fuel line from the fuel rail and drop it into a cup hit the key it should pump for 3sec check the amount 3 times it should be 175mls

    Quote Originally Posted by jetdave56 View Post
    The fuel filter itself I believe cannot be cleaned as it's built into the fuel pump but there is a fuel screen to catch debri on the bottom of the fuel pump so your gonna have to pull the pump , it is part of periodic maintenance and with your hrs (155) might be a good time to examine and clean..


  11. #10
    So Chriss, ambient mean humidity levels right now in the greater New York Area are 75% or better (with 80 degrees temp on top of that).

    I am in Needles CA w/ 115 degrees and 10% humidity right now. I am spinning a peak RPM of 7660 with stock 2014 310x with 2015 ECU

    The Humidity factor is dragging down your RPM's . . . Ultra's dont like Humidity combined with any type of heat. You are fine. Take a ride around Manhattan Island . . . (would love to join you). JB

  12. +1 by:


Page 1 of 9 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2011 300x stuck around 7000 RPMs
    By j0e1016 in forum Kawasaki How To & FAQs
    Replies: 7
    Last Post: 06-29-2015, 02:38 PM
  2. I gained 250 rpms!
    By Vern in forum 4-Tec Performance
    Replies: 50
    Last Post: 05-15-2008, 07:09 AM
  3. 155 4-tec wot rpms
    By buddydoo in forum Sea Doo Sport Boats
    Replies: 10
    Last Post: 05-12-2008, 10:02 PM
  4. ultra 250/rpm's-top speed??
    By monsoonmadness in forum Kawasaki PWC Performance (4-stroke)
    Replies: 18
    Last Post: 08-14-2007, 05:51 PM
  5. 03 GTX with New S/C ... Still down on RPMs and Speed..?
    By Fast05RXP in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 07-21-2006, 02:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •