Results 1 to 5 of 5
  1. #1

    Join Date
    Jun 2015
    Posts
    1

    help with my 2012 fx cruiser ho please....was working perfect...now it won't start!!!

    the ski won't start.....i hit the remote to unlock the ski and the light on the dash goes on as usual but no beeps as usual...
    i normally can then hear the ski mechanically unlock....now i don't hear anything except a sick electrical like whining sound coming from the area of the electrical box.
    if i try to start the ski ...nothing...wont turn over......
    the wining sound just continues until i unhook the battery.....when i reattach the battery sound is gone.
    the battery is less than a month old...the fuses are all intact.
    thanks for the help


  2. #2
    Hi Belmmj
    I had a 2012 HO but never had that happen but it sounds like the Ski is not unlocking properly and could be a numbe of things.
    The noise you hear sounds like the bilge pump which gets activated every time you unlock\lock your ski, so must be some power to do that and light the dash but maybe not enough to turn the motor

    1. Check your remote battery, try another remote if you have one.
    2. New battery does not mean its 100%, so put it on a charger for a few hours or jump to car battery etc to be sure.
    3. Another possibility is something such as a seized prop or an engine problem that is stopping the engine from turning over - check the cheap easy stuff first and report back and I am sure some of the more experienced guys can then zoom in on the exact cause.
    4.Check engine oil to make sure its not milky. ie Water contamination. This is a quick an easy check, pull the dip stick and rub the oil on your fingers to check its colour and consistency.

    I am hoping its just a low voltage condition and thats why there are no beeeps. Check the dash as well as there is a battery voltage check on you model as well.

    Regards Dave
    2012 FX HO (Sold)
    2011 FX SHO

  3. #3

    Problem Found?

    Did you find the answer to this issue? I'm having the same problem.


    Quote Originally Posted by belmmj View Post
    the ski won't start.....i hit the remote to unlock the ski and the light on the dash goes on as usual but no beeps as usual...
    i normally can then hear the ski mechanically unlock....now i don't hear anything except a sick electrical like whining sound coming from the area of the electrical box.
    if i try to start the ski ...nothing...wont turn over......
    the wining sound just continues until i unhook the battery.....when i reattach the battery sound is gone.
    the battery is less than a month old...the fuses are all intact.
    thanks for the help

  4. #4

    Join Date
    Apr 2015
    Location
    Wales, UK
    Posts
    1,551
    +1
    106
    Charge battery and try again anything below 12.7v will give you issues.... is dash waking up and showing voltage and hours on display?

  5. #5
    Nitro15's Avatar
    Join Date
    Apr 2017
    Location
    Jersey Shore
    Posts
    86
    +1
    13
    I also had a similar problem last summer. I attributed it to dirty/ corroded battery leads. Get some battery terminal cleaner and scrub them with a brush, you might be surprised as to the difference it can make. Hope this helps, Nick.

  6. +1 by:


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. help with my 02 fx 140
    By mrfunman01 in forum Yamaha PWC Performance (4-stroke)
    Replies: 2
    Last Post: 06-19-2014, 11:44 PM
  2. First Problems!!!! Please Help With 2012 FX Cruiser SHO???
    By mjealey in forum Yamaha PWC Performance (4-stroke)
    Replies: 49
    Last Post: 12-12-2013, 05:36 PM
  3. Help With GPS for FX Cruiser SHO???
    By mjealey in forum Yamaha PWC Performance (4-stroke)
    Replies: 8
    Last Post: 08-22-2012, 07:31 AM
  4. need help with my 2005 fx-ho motor
    By spyder3000gtvr4 in forum Yamaha PWC Performance (4-stroke)
    Replies: 0
    Last Post: 05-22-2012, 07:15 PM
  5. Replies: 8
    Last Post: 09-04-2010, 10:02 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •