Results 1 to 3 of 3
  1. #1

    Join Date
    Jun 2015
    Location
    Atlanta, GA
    Posts
    4

    94 SLT 750 - bilge pump?

    My 94 750 SLT is taking on water. A friend mentioned some Polaris' have a bilge pump. Does mine?


  2. #2
    David Drkvampire2001's Avatar
    Join Date
    Jul 2011
    Location
    Edgerton, Wisconsin, United States
    Posts
    2,872
    +1
    30
    Quote Originally Posted by gonu50 View Post
    My 94 750 SLT is taking on water. A friend mentioned some Polaris' have a bilge pump. Does mine?
    the 94 Polaris SLT 750 was not equipped with a powered Bilge pump, but infact what it has is a suction system, you will see 2 lines that are in the bottom of the bilge and go up high right under the seat, then down to exit out the hull, within the jetpump you will see a little i dont know hwo to explain it almost jet looking thing, coming out into the tail cone, when the jet pump is pushing water threw the pump, it will cause a suction on that tube, sucking out water.

    Now onto your ski taking on water, check all the hoses and make sure the hose clamps are tight, next, check the thru hull bearing for the drive shaft, this is the most common place for a leak to start. a good way to find the leak is strap the ski to the trailer, front and back, nice and tight, back it into the water with the seat off, and look into the hull, look for the leak, if you see nothing, start the engine, and then look for a leak, im going to put my money on the drive shaft seal. there is a cover over the driveshaft, but with engine off, and ski in the water you can put your hand under the cover and if its leaking will feel water dripping or possibly a small stream.

  3. #3

    Join Date
    Oct 2014
    Location
    Mohave County, AZ
    Posts
    155
    +1
    2
    Mine was taking on water. I thought it was my thru-hull bearing, it wasn't. It was the speedo nipple UNDER the bearing. Since I have no speedo line I went to autozone, got a zip tie and a vacuum cap

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 94 SLT 750 Oil Pump / Oiling Question - Converting to variable ratio pump
    By ThrottleOut in forum Polaris Open Discussion
    Replies: 4
    Last Post: 05-13-2013, 10:28 AM
  2. 94 SLT 750 - Primer Installation
    By mkulczyckyj in forum Polaris How To & FAQs
    Replies: 16
    Last Post: 07-29-2007, 09:31 AM
  3. 94 slt 750 fuel question
    By ace16a in forum Polaris Open Discussion
    Replies: 3
    Last Post: 07-08-2007, 11:10 PM
  4. 94 slt 750 problems
    By ace16a in forum Polaris Open Discussion
    Replies: 17
    Last Post: 05-28-2007, 03:45 PM
  5. '94 SLT 750...deal or no?
    By Fish Man in forum Polaris Open Discussion
    Replies: 5
    Last Post: 04-22-2007, 09:46 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •