Results 1 to 1 of 1
  1. #1

    WR500D Running Hot

    Just bought this a week ago been sitting about 10 yrs added some fuel and a battery and fired right up and idles great, took it to the lake and ran fine for about 10 min and went into limp mode and was very hot, when hooked it up to a hose the water came out of the exhaust/pump end so I unhooked the pickup line from the pump and water also flowed out then I removed the thermo cover and had water flowing out. What should I look at next?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	20150609_184613.jpg 
Views:	21 
Size:	83.1 KB 
ID:	361899   Click image for larger version. 

Name:	20150606_200139.jpg 
Views:	20 
Size:	118.0 KB 
ID:	361898  


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Mag cylinder running hot
    By desertmariner in forum Polaris Open Discussion
    Replies: 13
    Last Post: 03-31-2009, 09:46 PM
  2. october riding--running hot
    By seaobin in forum Polaris Open Discussion
    Replies: 3
    Last Post: 10-17-2008, 09:28 AM
  3. Front cylinder running hot
    By polaris 750SL in forum Polaris Open Discussion
    Replies: 6
    Last Post: 09-26-2008, 07:28 PM
  4. '99 slth running hot - hellp needed.. =)
    By fr33man in forum Polaris How To & FAQs
    Replies: 6
    Last Post: 06-16-2008, 11:51 AM
  5. Woohoo new motor starts, but is MAG running hot?
    By mystahagy in forum Polaris Open Discussion
    Replies: 10
    Last Post: 07-31-2007, 09:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •