Results 1 to 10 of 10
  1. #1
    Mike Greenwood's Avatar
    Join Date
    Jun 2015
    Location
    Tulsa, Oklahoma
    Posts
    701
    +1
    57

    Think I got duped. Msx 150 will only power up, idle, and flash engine light. What now

    Purchased a used Msx 150 with trailer for 2k. The ski's hull is flawless and has only 80 claimed hours on it. Owner pulled it to my house behind a AMG 55 and basically stated he didn't have time to fool with it. I have pulled the MAP sensors and they are clean. He stated them I has never been inverted. Compression test to be performed today. Any advice (other than returning it) would be appreciated.


  2. #2
    Moderator HiPeRcO's Avatar
    Join Date
    Jul 2007
    Location
    Upstate NY
    Posts
    2,627
    +1
    188
    Is the overtemp indicator on? If not, then there could be a problem with either the ppu or the etb that is putting the machine in limp mode.


  3. #3
    hill160881's Avatar
    Join Date
    Jun 2014
    Location
    The delta Ca
    Posts
    2,044
    +1
    248
    Unfortunately the take it back option would be smartest. To be honest the ski is worth less than a grand in this condition

    To start off with. Compression test and retorque. Is there gas in it? If so remove it all! Check the oil. Check the coolant resevor for sluge and oil in it. Then fire it up and see what it tells you. Sounds like ove heat limp mode.

    These se skis have a few common issues. I to got mine at around 80 hours and got another 100 hours before it blew. So you could get lucky. Good luck and we here on the hulk are the only help you are likely to get as no shop will even look at this ski much less service it.

    I am sure rip will chime in and fill in the gaps I left.


  4. #4
    Curious if the Msx 150 you bought, was on Tulsa craigslist. I saw one on there, the other day. That had 80 hours on it, would not rev past 2k.


  5. #5
    ripcuda's Avatar
    Join Date
    May 2010
    Location
    Newman Lake, WA
    Posts
    2,478
    +1
    186
    Welcome! Well... good thing is... you got a great ski... a much loved MSX hull... good looking... and sounds like in good shape. The bad is... it has an expensive-to-fix German engine that has a # of common problems in its 1st gen that came in the MSX 150. If you have the patience and mechanical skill (finding anyone to work on it is very unlikely) and a lot of money (most likely)... then you too can get this ski fixed and running well and have a great performer... great economy... and will last for years to come. But you aren't there yet.

    First off... you need a good, strong battery. Get a new one if in doubt. Weak or dying batteries cause troubleshooting headaches.

    Next, unless you know for certain the fuel is fresh... drain it (as Hill said) and replace with enough new Premium-only fuel for testing.

    Start the ski and let it idle for 30 seconds (on the trailer), then shut off. Pull dipstick, wipe, insert (do NOT thread it in), pull and read. The oil level should just barely be touching the stick. If it's up past MIN... there is way too much oil in it.

    When the ski is idling and you squeeze the throttle... what happens? What's the max RPM you see on the display? We need to know to help you.

    Is the 'check engine' dash indicator on all the time right after startup? Any other symbols illuminated on the dash... like the temp indictaor?

    Yes... you must do a compression test on each cylinder. Strong battery, plugs out, squeeze throttle while cranking. Tell us your #'s.

    Let's start there...

    Cheers!


  6. #6
    Mike Greenwood's Avatar
    Join Date
    Jun 2015
    Location
    Tulsa, Oklahoma
    Posts
    701
    +1
    57
    New gas, gapped plugs,coolant is not contaminated, map sensors /intake are clean, oil to correct level( per ripcuda's spec). Engine starts great, has 140-140 psi at head, new battery. Unit will start and run from 1500-3400rpm. Red light/service lcd is flashing. After reading All of your info I thought it best to order a SIFB from Randy at Weber Power. Still awaiting delivery. Had this unit out and was putting around last week and it would NOT SHUT OFF! With that said, I hope I am on the right track. Thanks Cuda for all your time.

  7. #7
    Mike Greenwood's Avatar
    Join Date
    Jun 2015
    Location
    Tulsa, Oklahoma
    Posts
    701
    +1
    57
    Could be the same unit. Was in great shape and trailer was perfect. Everyone ragged my A$$ for buying a Polaris. I need something to tinker on as my sportster and I decided to get in the way of a lovely drunk driver this April. The chap who sold it was pulling it with a bumper stickered AMG 55. I read between the lines as to his situation. After talking to all the shops here locally, figured he took it to ALL of them and was declined service.

  8. #8
    Moderator HiPeRcO's Avatar
    Join Date
    Jul 2007
    Location
    Upstate NY
    Posts
    2,627
    +1
    188
    3400 RPM limit (reverse limit) and can't turn off is almost certainly the SIFB.

  9. #9
    Sorry you got dinged up Mike! My 2002 Virage has given me fits, hoping this guy in Grove Okla, has her up and running by this Friday? Last year, had the service guy at Tommy Biffles, lakeside Polaris in Waggoner? He had my ski running perfect last year, till I winterized it, thought I could save some money, and fix it myself, well that didn't pan out. If this guy down the street in Grove, wasn't so close, would've made the longer drive back there, must admit, that pik of the msx 150 on Tulsa craigslist, did catch my eye! What a beauty that thing would be on the water.

  10. #10
    Mike Greenwood's Avatar
    Join Date
    Jun 2015
    Location
    Tulsa, Oklahoma
    Posts
    701
    +1
    57
    As to my delima.... Sifb bypass from Randy worked like a champ! Thanks guys

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 5
    Last Post: 09-15-2013, 12:04 AM
  2. 2004 MSX 150 will not stop running
    By tsummerl in forum MSX/Matrix
    Replies: 11
    Last Post: 11-18-2012, 09:57 PM
  3. MSX 150 Will Not go over 2900 RPMS
    By rtburns in forum MSX/Matrix
    Replies: 3
    Last Post: 07-01-2009, 10:47 PM
  4. 2004 MSX 150 will not stop running
    By tsummerl in forum Polaris Open Discussion
    Replies: 4
    Last Post: 11-13-2008, 05:11 PM
  5. MSX 150 runs only at 7000 t/mn
    By NORWAX in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 09-27-2006, 11:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •