Results 1 to 8 of 8
  1. #1
    Mighty Mouse's Avatar
    Join Date
    Feb 2011
    Location
    Mississippi
    Posts
    898
    +1
    23

    SC Impeller touching SC Case

    I am rebuilding my SC on my 185 and everything is coming together as it should except when I put the SC halves back together the impeller is touching the case just a small amount. I dont think that should be. I know wear rings sometimes are tight, but is this acceptable? Could the bearings be out of spec or maybe not shaft not completely seated into housing?


  2. #2
    swlamarshrunner's Avatar
    Join Date
    Dec 2014
    Location
    Lake Charles, Louisiana
    Posts
    548
    +1
    108
    There needs to be a certain clearance but I do not know what amount exactly.

  3. #3
    Riko's Avatar
    Join Date
    Jul 2014
    Location
    Greece
    Posts
    110
    +1
    6
    You install shims if you want to up the slip limit..
    No Sc wheel shouldn't touch the Sc cases at all!Was the rebuild kit OEM?

  4. #4
    Mighty Mouse's Avatar
    Join Date
    Feb 2011
    Location
    Mississippi
    Posts
    898
    +1
    23
    Not concerning slip. Aftermarket kit. I guess I'll take it apart and check the seating on the bearings to be sure they are square. Not sure how they could be out though.

  5. #5
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,700
    +1
    852
    You obviously did not get the shaft/bearing assembly pressed together completely OR the the fan did not seat on the shaft completely....The fan should NOT touch the front housing at all....

  6. #6
    Mighty Mouse's Avatar
    Join Date
    Feb 2011
    Location
    Mississippi
    Posts
    898
    +1
    23
    Pulled it all apart and put back together. Now all is well. Not sure why the issue. But all is well.

  7. #7
    ncdoo's Avatar
    Join Date
    Nov 2007
    Location
    Eastern NC
    Posts
    1,637
    +1
    175
    Hope you didn't re-use the bearings.

  8. #8
    Mighty Mouse's Avatar
    Join Date
    Feb 2011
    Location
    Mississippi
    Posts
    898
    +1
    23
    The only issue I saw with pressing the bearings incorrectly was when you pressed the shaft into the housing with the bearing on the shaft. Dont see anyway around not pressing on the inner bearing on that one. Putting in the freezer helps. They go in pretty easy. Other than that pressing bearing in and out shouldn't be an issue.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Splitting the SC case
    By imp0ster in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-28-2014, 02:47 PM
  2. SS wear ring installed but IMPELLER touches side
    By 03mustardrockets in forum 4-Tec Performance
    Replies: 22
    Last Post: 08-20-2009, 02:27 PM
  3. RUDE SC case and stock SC
    By BlackHawk in forum 4-Tec Performance
    Replies: 6
    Last Post: 09-11-2008, 08:15 PM
  4. Need some help! Impeller touching wear ring
    By awague2 in forum 2-Stroke Performance
    Replies: 6
    Last Post: 06-02-2008, 04:20 PM
  5. SC impeller
    By shhr in forum 4-Tec Performance
    Replies: 14
    Last Post: 05-02-2005, 09:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •