Results 1 to 5 of 5
  1. #1

    2004 GTX Reverse Problem

    The reverse on my seadoo isn't fully working. I can pull the lever to put it in reverse; however, when I put the lever back into forward, it stays in reverse. It works out of the water only. I found where the problem appears to be coming from. The cable connecting the the lever to the bucket had a part come disconnected from the hull. I have tried to screw it back in with no success. I'm not sure if I need to take the pump off, or how to fix it. Just seeing if anyone has had a problem like this, or knows if it can be fixed without bring it in to get service.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	photo.jpg 
Views:	180 
Size:	57.7 KB 
ID:	361701  


  2. #2
    It appears the insert has broken off. There is plenty of write-ups pertaining to this issue. I replaced both of mines (reverse and steering) with aluminum fittings.

    http://www.greenhulk.net/forums/show...e+cable+broken
    Last edited by Shacho762; 06-09-2015 at 04:58 PM.

  3. #3
    3ftDeep's Avatar
    Join Date
    Mar 2014
    Location
    White Rock, BC
    Posts
    381
    +1
    112
    I've heard of this problem, but never actually saw a post until now. I replaced my steering insert with an aluminum, but thought I was being over-cautious. I highly recommend replacing it with an aluminum one instead of the stock Sea-Doo one.

  4. #4
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    3,269
    +1
    181
    Yep, broken cable nut. The ones I've fixed have been sitting in the water at slips. I would guess the long term water exposure rots the plastic.

  5. #5
    I have struggled to get the old threads out. I tried with a flat head screw driver and didn't have much success.

    Also, how do you disconnect the rod from the reverse cable?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. seadoo gtx 185 2004 strange starting problem
    By howellsy42 in forum 4-Tec Performance
    Replies: 9
    Last Post: 06-09-2015, 04:50 PM
  2. Seadoo 2004 GTX SC Performance Problems
    By Biasedyeti in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-19-2015, 11:09 AM
  3. 2004 Gtx Supercharged 185 problems
    By rmeeks1214 in forum 4-Tec Performance
    Replies: 10
    Last Post: 09-29-2014, 03:37 PM
  4. 03 gtx reverse problem
    By 03gtx in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 07-16-2011, 09:31 AM
  5. 2004 GTX SC with plastic pump?
    By Green Hulk in forum 4-Tec Performance
    Replies: 17
    Last Post: 08-15-2005, 09:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •