Results 1 to 9 of 9

Thread: Eh oh!

  1. #1
    cmthomp2's Avatar
    Join Date
    Mar 2010
    Location
    Gap PA
    Posts
    23

    Eh oh!

    My rxp x blew up this weekend. I had gotten water in the engine 2 summers ago. The ski has had trouble starting ever since then. Ive read several threads on here where skis have had the same issues. Well... anyways im prolly gonna need a new motor. Any opinions on what direction i should go. Ive talked to several shops and they have all said they use sbt engines.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Message_1433777634512.jpg 
Views:	155 
Size:	77.2 KB 
ID:	361653  


  2. #2
    DooX's Avatar
    Join Date
    May 2015
    Location
    S.W. Ontario
    Posts
    271
    +1
    7
    Quote Originally Posted by cmthomp2 View Post
    My rxp x blew up this weekend. I had gotten water in the engine 2 summers ago. The ski has had trouble starting ever since then. Ive read several threads on here where skis have had the same issues. Well... anyways im prolly gonna need a new motor. Any opinions on what direction i should go. Ive talked to several shops and they have all said they use sbt engines.
    Sorry to hear that. What broke?
    How many hours? Any mods?

  3. #3
    cmthomp2's Avatar
    Join Date
    Mar 2010
    Location
    Gap PA
    Posts
    23
    Not sure what broke yet. Hull is full of oil and i found those hunks of metal.im assuming i threw a bearing 95hrs on ski. No mods.

  4. #4
    Treemn's Avatar
    Join Date
    Jun 2007
    Location
    Coral Springs FL
    Posts
    3,454
    +1
    837
    NO SBT long block from seadoo or used from reputable seller

  5. +1 by:


  6. #5
    DooX's Avatar
    Join Date
    May 2015
    Location
    S.W. Ontario
    Posts
    271
    +1
    7
    Quote Originally Posted by cmthomp2 View Post
    Not sure what broke yet. Hull is full of oil and i found those hunks of metal.im assuming i threw a bearing 95hrs on ski. No mods.
    Hummm....its never good when you find pieces of your block in the hull.

  7. #6
    ncdoo's Avatar
    Join Date
    Nov 2007
    Location
    Eastern NC
    Posts
    1,655
    +1
    176
    Most likely threw a rod. Go back with OEM block and parts.

  8. +1 by:


  9. #7

    Join Date
    May 2012
    Location
    California
    Posts
    1,825
    +1
    163
    no way on the sbt, customer just brought me an sbt engine in pieces and it looks like a boat anchor. Terrible workmanship.

  10. +1 by:


  11. #8
    cmthomp2's Avatar
    Join Date
    Mar 2010
    Location
    Gap PA
    Posts
    23
    Just talked to ses engines. They seemed knowledgable about the engines. From their website it looks like they do great work and use good parts. Anyone have any experience with them?

  12. #9
    Branden's Avatar
    Join Date
    Aug 2014
    Location
    Cape Coral, Fl
    Posts
    1,600
    +1
    321
    Yea looks like you vented the block.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. oh no
    By stickem in forum 4-Tec Performance
    Replies: 33
    Last Post: 05-19-2006, 06:03 PM
  2. Uh Oh, GTX is dooin' 73.1 mph
    By Red Devil in forum 4-Tec Performance
    Replies: 24
    Last Post: 05-19-2006, 07:29 AM
  3. Man, Tight fit RRic plumbing and 4in intake!Oh yea SCer back
    By Water4fire in forum 4-Tec Performance
    Replies: 19
    Last Post: 05-02-2006, 05:10 PM
  4. oh shit my engine
    By stickem in forum 4-Tec Performance
    Replies: 35
    Last Post: 03-14-2006, 06:10 PM
  5. OH SHIT! I flipped my RXP!
    By Green Hulk in forum Shops, Tools and Tricks
    Replies: 27
    Last Post: 03-02-2006, 04:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •