Results 1 to 2 of 2
  1. #1

    1999 kawasaki ultra 150 water/cooling pump

    ultra150/99 water spout not pumping water , ski has had a rattle for some time now , two years I have own with no troubles , today red light shows up and notice high temp warning and no water from right hand spout , could this have been a bearing all this time ? any help greatly appreciated.


  2. #2
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,998
    +1
    433
    The rattle is probably from a bad pump bearing. Running it like that for a long time will destroy your jet pump.

    No water means that you have a blockage in the cooling system somewhere. The lack of water coming from the pisser indicates that the brass elbow on top of the front cylinder is likely plugged with debris. If it's plugged, odds are that the others are as well. It's likely that there is trash in the exhaust cooling system, too.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. F.S. 2001 and 1999 Kawasaki Ultra 150's PARTS
    By signdaddy in forum Kawasaki Classifieds
    Replies: 14
    Last Post: 06-09-2016, 03:47 PM
  2. Replies: 1
    Last Post: 03-29-2012, 09:02 PM
  3. 1999 kawasaki ultra 150 manual
    By blayden in forum Kawasaki Open Discussion
    Replies: 2
    Last Post: 07-27-2009, 05:19 PM
  4. 1999 Kawasaki Ultra 150
    By cfree5119 in forum Kawasaki Classifieds
    Replies: 3
    Last Post: 05-30-2009, 09:28 PM
  5. Kawasaki Ultra 150 Water Intake
    By Mack77 in forum Kawasaki Open Discussion
    Replies: 4
    Last Post: 03-23-2009, 08:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •