Results 1 to 7 of 7
  1. #1

    Join Date
    Jul 2014
    Posts
    23
    +1
    1

    GTX 215 Power Question

    I purchased a pair of skis with very low hours last year and I'm having an issue with one of them. I purchased a 2012 RXP-X 260 and a 2010 GTX 215 iS. I'm have a strange issue with the GTX. I purchased it with 3-hours on it and it now has a little over 20-hours. The power doesn't seem to be available. I can't get more than about 6K RPMs and barely over 40-MPH. It's almost as if the normal key is operating like a learning key. The machine otherwise runs perfectly. Is there some reset or dealer switch that turns the power on after some sort of break-in period, e.g. after 10-hours or so? The power comes on very slow even when Sport mode is enabled. I had a 2009 GTX 155 that has way more power and acceleration. I think there's something wrong with the ECU. I'm debating on getting a programmer to reflash the ECU or maybe biting the bullet and taking it to the dealer for a check. What should I expect from this ski? I'm assuming mid 60's MPH and much higher RPMs, also much quicker acceleration. It seems like this issue is all ECU related. Any help would be greatly appreciated, thanks in advance for the responses.


  2. #2
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,683
    +1
    948
    Check the SC'er Hoses and SC'er. As the first thing that suggest a SC'er issue is only making 6000rpm's.

  3. +1 by:


  4. #3

    Join Date
    Jul 2014
    Posts
    23
    +1
    1
    That makes sense, it just feels like everything is running ok but for sure, I need to check the SC. A little lazy on my part. The iS skis I'm finding to be a pain in the ass to inspect and do maintenance on. My wife and kids love the ride but it doesn't make dad happy in the garage.

  5. #4

    Join Date
    Jul 2014
    Posts
    23
    +1
    1
    Any idea what the RPM limit should be for a 215 iS Sea-Doo? I don't see any issues or problems looking down into the engine bay. The machine was run a bunch last weekend and no real issues observed with the exception of performance. I think I can hear the Super Charger.

  6. #5
    Vern's Avatar
    Join Date
    May 2005
    Location
    Grand Haven, MI
    Posts
    3,575
    +1
    129
    RPM limit should be around 8100ish. You will not see any issues just looking ... you need to grab and pull on every clamped area of the SC to IC/TB and make sure you cannot pull the hoses off. If that is not the issue, then it is very likely that your SC needs attention and is not working correctly. Did it run correctly when you bought it, or the first time you had it out, or has it always only gone 6000 rpm? If so, you should not have bought it that way ... a broken SC at such low hours is uncommon, but if it happens, it can cause damage and $$. You need to roll up your sleeves and get much deeper in to find your issue - looking won't work. Maybe post your location and see if someone local to you is willing to come over and take a look with you.

  7. #6
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,683
    +1
    948
    Ok with the new skis they are limited to 8040 Rpms not 8100 but it could see a bit more as mine does until the limiters bring it down to 8040, but since your only seeing 6000 then it suggest a SCer issue! Hose off or SCer gone/out, and if you keep ridding it like this and it is the SCer than your about to have a whole bunch more problems, so stop ridding it! Period! The IS model is harder to check SCer hoses but start there and also SCer.

  8. #7

    Join Date
    Jul 2014
    Posts
    23
    +1
    1
    Are there any threads that provide any guidance on how to work on the iS machines? I haven't found any. I may be forced to take it somewhere. It looks like a huge pain in the ass to take the top of the machine apart to get to the engine.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 8
    Last Post: 02-07-2013, 09:38 PM
  2. 2008 gtx-215 power loss
    By dallasquick in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 08-16-2009, 09:32 PM
  3. 2008 gtx-215 power loss
    By dallasquick in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 08-16-2009, 09:16 PM
  4. 03 gtx sc mod questions
    By fencer50/24 in forum 4-Tec Performance
    Replies: 12
    Last Post: 04-18-2007, 10:41 AM
  5. 2003 GTX SC acceleration question
    By krummel21 in forum 4-Tec Performance
    Replies: 32
    Last Post: 03-16-2007, 08:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •