Results 1 to 4 of 4
  1. #1

    Join Date
    May 2015
    Location
    Fargo, North Dakota
    Posts
    6

    Grinding noise in neutral

    I just bought a 2015 2-UP HO Spark. I had it in the water last weekend for the first time. When I first unloaded it and started it, I noticed that when it is in idle mode or neutral that it kind of sounds like a grinding is happening. Oil level was fine, everything runs fine, no warnings on the screen. Am I just being paranoid or is there something that I should be checking on?


  2. #2
    GasResearch-VT.SE's Avatar
    Join Date
    Nov 2012
    Location
    Melbourne, Australia
    Posts
    1,170
    +1
    207
    Like a metal to metal rattle?Normal.. Its the pump

  3. +1 by:


  4. #3
    Mine is quite in the water. However outside the water it rattles a lot but is normal.

  5. #4

    Join Date
    May 2015
    Location
    Fargo, North Dakota
    Posts
    6
    Ok, that's relieving to hear. Thanks!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Rattling noise in back
    By billywilly in forum Polaris Open Discussion
    Replies: 4
    Last Post: 07-04-2007, 09:10 AM
  2. Extremely rough engine yesterday- grinding noise
    By vidbuster in forum 4-Tec Performance
    Replies: 8
    Last Post: 04-26-2007, 11:26 AM
  3. Clank Noises in New O7 FX HO
    By mdilabs in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 04-04-2007, 01:36 PM
  4. Help diagnosing a grinding noise? Z
    By ZMANN in forum Polaris Open Discussion
    Replies: 12
    Last Post: 10-10-2006, 11:02 PM
  5. no drive and bad grinding noise
    By timbo in forum 4-Tec Performance
    Replies: 19
    Last Post: 01-27-2006, 10:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •