Results 1 to 3 of 3
  1. #1
    FZSBert's Avatar
    Join Date
    Jun 2015
    Location
    Jacksonville, FL
    Posts
    9

    09 FZS main fuse (20amp) keeps blowing

    anybody else ever have this issue?


  2. #2

    Join Date
    Jul 2005
    Location
    Central North Carolina
    Posts
    4,089
    +1
    608
    up plug the bilge pump at the wiring connection and try it with a new fuse . you may have a short in the bilge pump causing this to blow the fuse. Tommy Jordan

  3. +1 by:


  4. #3
    FZSBert's Avatar
    Join Date
    Jun 2015
    Location
    Jacksonville, FL
    Posts
    9
    thx Tommy. i'll give that a try

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2010 FZS Blowing main fuse
    By Salty Dog in forum Yamaha PWC Performance (4-stroke)
    Replies: 0
    Last Post: 07-15-2012, 04:07 PM
  2. 08 SHO - why would main fuse keep blowing?
    By idealrides in forum Yamaha PWC Performance (4-stroke)
    Replies: 9
    Last Post: 08-03-2011, 07:49 PM
  3. trim fuse keeps blowing
    By rxpiowa in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 07-25-2010, 01:41 AM
  4. maybe theres a quick answer to this...fuse keeps blowing in my gp1300r
    By MJE in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 07-15-2009, 09:48 PM
  5. MFD keeps blowing fuses
    By brianstrange in forum Polaris Open Discussion
    Replies: 10
    Last Post: 05-30-2008, 02:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •