Results 1 to 2 of 2
  1. #1

    98 Polaris SLTH No spark Help!!

    I have saw a lot about this online. But not sure where to start. Put new battery in to start up for riding this year and no spark. Ran fine last year did get bad gas that I had to drain but I saw spark when I last parked it. Checked plug on block no fire. Checked fuses. Maybe coil ? Mine is a solid type looks like the spark plug wires are built in...Have checked OHMs on this just not sure what it should be. Thanks for help!! Ready to ride..


  2. #2

    Join Date
    Oct 2014
    Location
    Mohave County, AZ
    Posts
    155
    +1
    2
    The SLTH is the red motor, correct? Is your CDI updated? Read K477's site it's bound to be helpful.

  3. +1 by:


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 polaris virage no spark, HELP!
    By robmeyer in forum Polaris Open Discussion
    Replies: 25
    Last Post: 06-12-2017, 12:29 PM
  2. 01 polaris virage no spark help
    By 01polaris in forum Polaris Projects
    Replies: 1
    Last Post: 07-27-2015, 01:35 AM
  3. 2001 Polaris Virage no spark ..help
    By Ratrace in forum Polaris Open Discussion
    Replies: 3
    Last Post: 09-30-2013, 06:45 PM
  4. Polaris slth no spark ,stator reads bad and cdi has bubbles on it
    By J max in forum Polaris Open Discussion
    Replies: 0
    Last Post: 08-13-2013, 04:27 PM
  5. 98 polaris slth Keihin cdk II carbs, no high speed needle, wtf?
    By bigjump300 in forum Polaris How To & FAQs
    Replies: 13
    Last Post: 03-28-2007, 11:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •