Results 1 to 9 of 9
  1. #1

    Join Date
    Oct 2014
    Posts
    20

    RPM going up and down, HELP! 2006 RXP

    Hello,

    My 2006 RXP has been having issues lately with keeping RPM @8100. If I am just doing donuts, RPM stays at 8100 without issues but if just riding straight, it goes to 6800 and back to 8100, then drops again and builds back up. I checked the supercharger and it is not lose at all. Cannot spin it by hand. Just rebuilt it last summer with new washers. Thinking it could be an air intake system issue but not even sure where to check for the filter. Not sure if its a cavitation issue, any and all input is greatly appreciated. Thank you ahead.


  2. #2
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,683
    +1
    516
    no air filters
    but fuel pump/filters could be your problem
    start with the easy stuff
    check hose clamps
    with a cavitation issue the rpms stays high not low

  3. #3

    Join Date
    Oct 2014
    Posts
    20
    Would the fuel pump issue come up all the time and not just when going straight. Also do you have an approx place to look for fuel pump filter? Checking all clamps now as that was something that was replaced last summer due to some being rusted out.

  4. #4
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,683
    +1
    516
    fuel filter is on the fuel pump in the tank
    a bad fuel filter usually works fine/good at lower rpms
    and you can tell the motor is not running right in high rpms
    with low boost the motor runs good but just dont make big power

  5. #5

    Join Date
    Oct 2014
    Posts
    20
    Just spoke to dad whos taking a look into things now, said that the prop is bent.. wonder if its thats the issue with it sucking air or something... RPM's dont drop when doing donuts in circles because the back sits low but wonder if its coming up too high when going in straight line and sucks air...(please correct me if im wrong here) going to take off the prop tomorrow and check it. Want the solas one anyways so it'll be a reason to upgrade hahah.. Thanks very much for input, I'll update tomorrow

  6. #6

    Join Date
    Oct 2014
    Posts
    20
    Put a new Solas impeller in today and also found out that my oil was overfilled by quite a bit so drained to middle mark (while engine is hot). RPM still going to about 8050 and then drops back down to mid 6000's, attempts to build again and drops. Oil was drained after testing with new impeller/wear ring. Anyone have any ideas why RPM's wont hold. They were fine last season after supercharger rebuild but this season I haven't gotten a chance to ride at all. Locked camshaft and tested torque on supercharger, had no issues so do not think its slipping, but maybe? Any ideas are greatly appreciated at this point. Again, have not tested after draining oil but do not think that overfilled oil would cause RPM's to go up and down?

  7. #7
    rmk82nd's Avatar
    Join Date
    Apr 2011
    Location
    Charlotte, NC
    Posts
    370
    +1
    4
    Test the intercooler for leaks. I had a similar problem end of last year.

  8. #8

    Join Date
    Oct 2014
    Posts
    20
    Quote Originally Posted by rmk82nd View Post
    Test the intercooler for leaks. I had a similar problem end of last year.
    You mean the intake manifold, if not where do I locate it?

    Also think it could be pressure sensor?

  9. #9

    Join Date
    Oct 2014
    Posts
    20
    It was the spark plugs, in anyone else gets this issue...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RPM going up and down, please help!
    By Swe_daniel in forum 4-Tec Performance
    Replies: 1
    Last Post: 12-05-2013, 04:52 PM
  2. Going turbo and need help
    By josh_m in forum 4-Tec Performance
    Replies: 20
    Last Post: 06-13-2010, 10:59 PM
  3. Need Help - 2006 RXP Oil Pump Housing Cracked
    By Mason Lake in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-10-2009, 08:35 PM
  4. Jetski RPMs going up, but ski not going?
    By SLC in forum Kawasaki PWC Performance (2-stroke)
    Replies: 3
    Last Post: 06-10-2009, 09:04 AM
  5. Need Help 2006 RXP (Viper Red) REG #
    By blowbyu in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 02-13-2009, 09:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •