Results 1 to 7 of 7

Thread: help

  1. #1

    help

    Hello everyone new to jet ski I bought a 2014 310x and I have a question the clean out ports in the back of the ski are they supposed to be plugged while running it. Thanks for the help.h


  2. #2
    Take the time to smile sirbreaksalot's Avatar
    Join Date
    Jun 2007
    Location
    Brisvegas
    Posts
    4,592
    +1
    710
    Read your owner manual please from front to back

    Waz

    No they dont

  3. +1 by:


  4. #3
    What he said ^^^

  5. #4
    "just sayin".. jetdave56's Avatar
    Join Date
    Nov 2008
    Location
    JERSEY SHORE
    Posts
    4,566
    +1
    623
    Just a reminder... never hook up to the wrong port by accident when flushing ,engine must be running (black port) and engine is off to clean IC (grey port)...

    Some Ultra owners use a dual port flushing system with a Y fitting that flushes engine/exhaust and IC at the same time,BUT engine must be running...

  6. #5
    I did thank you in the section for flushing it told to remove caps. Thanks for your help.

  7. #6
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,782
    +1
    614
    there are no caps!! leave them open at all times, some choose to leave the hose barbs screwed in some remove them. water needs to exit them once the engine is running on the water.

  8. #7
    Olomana's Avatar
    Join Date
    Jan 2011
    Location
    Tahiti, French Polynesia
    Posts
    1,419
    +1
    76
    The dealer should have least told you how to flush the ski.
    But even so, you should read the owner manual!
    If you flush your ski the wrong way, it will not be under warranty!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. NEED HELP!!!!!
    By MartyRXP in forum 4-Tec Performance
    Replies: 15
    Last Post: 05-20-2018, 11:35 PM
  2. Replies: 1
    Last Post: 05-18-2005, 07:49 AM
  3. RXP Handling !! Anyone help please
    By rxp_boy in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-17-2005, 02:33 PM
  4. help!!!
    By jonstephens in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-16-2005, 10:47 AM
  5. I need help remove stock intercooler
    By orc in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-13-2005, 04:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •