Results 1 to 8 of 8
  1. #1
    j0e1016's Avatar
    Join Date
    Apr 2011
    Location
    NJ
    Posts
    52
    +1
    3

    2011 300x stuck around 7000 RPMs

    When I put it away last winter it was running fine. Iíve taken it out twice this spring and when I get above 7000 it feels like Iím hitting a speed limiter. The ski usually does 7900-8100 with the R&D SCOM. The rest of the ski is stock. Iíve got 140 hours on it. Before I put it away I changed the exhaust filter, the oil and checked the super charger belt. Before for the first run of the year I put 4 new spark plugs in. I was thinking of putting the old spark plugs and giving it one more try before taking it to the dealership. Any suggestions would be greatly appreciated.


  2. #2
    "just sayin".. jetdave56's Avatar
    Join Date
    Nov 2008
    Location
    JERSEY SHORE
    Posts
    4,522
    +1
    623
    Have you ever cleaned the IC?


    very common to have the cooling fins clogged with oil and not bringing the neccessary cool air into the the TB though the IC is being water cooled...

    Also you say "above 7000rpms" ..where is your visual peak 7200-7300?

  3. #3
    j0e1016's Avatar
    Join Date
    Apr 2011
    Location
    NJ
    Posts
    52
    +1
    3
    I usually flush my intercooler with simple green twice a year. About 7350 in the most I've been seeing.



    Quote Originally Posted by jetdave56 View Post
    Have you ever cleaned the IC?


    very common to have the cooling fins clogged with oil and not bringing the neccessary cool air into the the TB though the IC is being water cooled...

    Also you say "above 7000rpms" ..where is your visual peak 7200-7300?

  4. #4
    "just sayin".. jetdave56's Avatar
    Join Date
    Nov 2008
    Location
    JERSEY SHORE
    Posts
    4,522
    +1
    623
    Ok..with 140 hrs check the cylinder compression ,should be within spec..

    lets get the easy diagnosis tests out of the way...

  5. #5
    "just sayin".. jetdave56's Avatar
    Join Date
    Nov 2008
    Location
    JERSEY SHORE
    Posts
    4,522
    +1
    623
    Oh forgot to mention as this is common problem I also overlooked and you said you recently changed Filter and cleaned IC..

    what boost #s are you getting?.. Does it climb to 10-12 -15 lbs WOT quickly then drops to let's say 8-10 lbs?

    thats a boost leak most probably somewhere between the SC >IC> BOV>TB hoses are not clamped real snug Also if you still have hose on the bypass valve on the IC that could be leaking too..

    What is your GPS max speed,were you able to check that with a phone app?

  6. #6
    j0e1016's Avatar
    Join Date
    Apr 2011
    Location
    NJ
    Posts
    52
    +1
    3
    GPS was saying 59mph last week. The boost is holding steady at 15psi while at WOT. I should be able to check the compression Thursday or Friday.

  7. #7
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    funny how everyone always says check compression ive never found one down yet causing these problems.
    the best 2min tip i can give anyone if they choose to listen is check your fuel pressure at the 3sec prime. drop the hose off the fuel rail into a cup measure the fuel output a few times on the prime. there is a masive difference between what it pumps from new to what the minimum is gains and losses are won here. min is 83-88mls for 3 sec a clean filter yields 175mls. its a little known tip that guys and shops know nothing about. it causes fuel starvation at wot.

  8. +1 by:


  9. #8
    Gsmith88's Avatar
    Join Date
    Mar 2015
    Location
    Li , New York
    Posts
    862
    +1
    108
    Good info nic
    and if fuel pressure is low?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2011 300x 155 hrs down 250 rpm 3mph and some boost
    By Chris288 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 81
    Last Post: 09-13-2015, 12:41 PM
  2. R12-X with misfire around 2000 rpm
    By hondaturboboy in forum Honda Open Discussion
    Replies: 5
    Last Post: 09-15-2008, 02:53 PM
  3. help..06 gpr rough idle...around 2900 rpms on trailer cable recall fix done
    By MJE in forum Yamaha PWC Performance (2-stroke)
    Replies: 13
    Last Post: 07-11-2008, 04:59 PM
  4. Bogging at around 5k rpm after D-Plate + Jetworks.
    By PuprleNuprleGPR in forum Yamaha PWC Performance (2-stroke)
    Replies: 14
    Last Post: 08-08-2006, 01:44 PM
  5. RXP surging around 6000 rpms ...
    By Vern in forum 4-Tec Performance
    Replies: 13
    Last Post: 10-04-2005, 01:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •