Results 1 to 5 of 5
  1. #1

    Lightbulb Yamaha 2008 ar212x oil light flashing on one side

    so we put the boat in today and it runs completely normal, however after a little the starboard engine temp light will flash and keep flashing until i turn the engine off. the boat runs completely fine, can anyone help me out with this I'm trying to fix it here at home and not have to take it to the shop.
    Thanks in advanced
    Last edited by foxrider56; 05-25-2015 at 08:29 PM.


  2. #2

  3. #3
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    7,549
    +1
    1,806
    so is it an overheat or oil pressure alert?

    Given the cost of the engine you certainly don't want to be guessing for longer then 5 seconds.

    I don't recall you being able to pull codes from a Yamaha boat dash..that the case hre?

    best to get tot he bottom of this before the engine decides it's had enough of running with low oil pressure or a hotspot.

  4. #4
    sorry its a temp sensor, it runs completely fine, i remember reading somewhere if its actually overheating the engine will drop down to 3500 rpm and it doesn't do that. also i tried to put it in no wake mode, the one engine does it completely fine but the one with the light on doesn't. so what I've read somewhere is that means its like a trouble code? how do you read the code?
    Quote Originally Posted by nmpeter View Post
    so is it an overheat or oil pressure alert?

    Given the cost of the engine you certainly don't want to be guessing for longer then 5 seconds.

    I don't recall you being able to pull codes from a Yamaha boat dash..that the case hre?

    best to get tot he bottom of this before the engine decides it's had enough of running with low oil pressure or a hotspot.

  5. #5
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    7,549
    +1
    1,806
    I'd suggest you get a manual, it will detail what you an do and exactly how to do it.

    a overheat condition should put the engine into limp mode to protect it from damage

    a check engine indication _will_ prevent the engine from going into no wake mode.

    To determine what the error is, count the flashes.

    It will flash the first digit..then a brief pause, then the second digit.

    13 Incorrect pickup coil signal
    15 Incorrect engine temp sensor signal
    18 Incorrect throttle position sensor signal
    19 Incorrect battery voltage
    23 Incorrect intake air temperature sensor signal
    24 Incorrect cam position sensor signal
    29 Incorrect intake air pressure sensor signal
    48 Incorrect data transmission
    53 Exhaust temp sensor malfunction
    54 Incorrect bypass valve motor signal
    63 Incorrect intake air system signal


    Since you say the engines are "running fine", it might well be a defective temp sensor which is reporting either absolute zero or 2000 degrees, both of which are typically out of range.

    I'd suggest taking it to a shop. It may cost far more to do it yourself.

    Your boat books at over 20k and is not the platform I would suggest a novice tech with basic tools tackle as a first repair project.

    A tech with a code reader can pinpoint and repair this problem for under $500 likely

    You can always buy a code reder for a couple of hundred bucks if you are serious about doing your own repairs.

    Still, it's a pricey platform that isn't all that easy to work on.

    Now if the boat is in a slip and you have no trailer well that's a different story.

    For now, you can either try to figure the code out ( which may require you torture that engine some more) or go with my advice..depending on the transport/shop situation.

    This is no small boat as far as things go, to be jacking in and out of the water while trying to figure out a problem is going to get old really fast.

    Running on a flush hose is not a solution by the way. You'll overheat the driveline if you run it out of water too long.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help, 2008 rxpx oil light coming on ang going into limp mode
    By Turboted in forum 4-Tec Performance
    Replies: 19
    Last Post: 09-17-2013, 11:45 PM
  2. Oil light comes on
    By super_gtx in forum 4-Tec Performance
    Replies: 18
    Last Post: 08-17-2008, 06:29 PM
  3. 2003 sea doo oil light stays on
    By tony hickman in forum 2-Stroke Performance
    Replies: 2
    Last Post: 07-01-2008, 07:26 AM
  4. Getting the oil light off on my GP....
    By Waveblaster785 in forum Yamaha Old School Skis
    Replies: 5
    Last Post: 05-19-2008, 01:02 PM
  5. 2003 GTX SC oil light comes on but oil level is fine??
    By djbauer in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 07-25-2006, 04:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •