Results 1 to 6 of 6
  1. #1

    Join Date
    Jul 2012
    Location
    Little Cypress Texas
    Posts
    34

    Is this a major problem?

    Sucked something up earlier and ski became sluggish out of the hole. Just a small vibration before actually taking off.. Got home and pulled intake grate and noticed this. Major problem? Can I ride this weekend with this piece like this? What's the part called? Thanks for your help. Bryan
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_20150523_154952204.jpg 
Views:	124 
Size:	35.2 KB 
ID:	359989  


  2. #2

    Join Date
    Jul 2012
    Location
    Little Cypress Texas
    Posts
    34
    I'm talking about the rubber piece that's around the shaft near impeller. You can see the rip on the top left of picture.

  3. #3
    Im not sure if u can ride or not, but the piece is called "impeller boot"

  4. #4
    carlosdelgado's Avatar
    Join Date
    Dec 2008
    Location
    Haverhill, South Florida
    Posts
    1,665
    +1
    103
    You should Not ride your ski the way it's now. Specially the Vibrations it will cause. If you can, try to just cut it off as much as possible until you a get to remove the pump and either replace it with a new one or just remove the hole thing. You can ride the ski with no nose cone.

  5. #5

    Join Date
    Jul 2012
    Location
    Little Cypress Texas
    Posts
    34
    Thanks for the response. So if I cut this off I shouldn't put ski in water until I get it 100% fixed?

  6. #6
    Tiny's Avatar
    Join Date
    Sep 2006
    Location
    The Atl
    Posts
    3,600
    +1
    590
    Take/cut it off and your ok...It might cavitate a little bit but you will be ok until you get it fixed..

  7. +1 by:


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Is this a known problem with 08/09 RXT ??
    By Glassfinder in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 07-31-2011, 08:30 PM
  2. Is this normal or a problem ?
    By hiluxal in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 06-05-2011, 12:50 AM
  3. Is this a problem?
    By lashk in forum Sea Doo Sport Boats
    Replies: 1
    Last Post: 05-04-2009, 01:30 PM
  4. is this a BIG problem? what are my options?
    By alfmoney in forum Sea Doo Open Discussion
    Replies: 16
    Last Post: 02-11-2009, 07:52 AM
  5. think this is a power valve problem?
    By wakewhornc in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 08-29-2008, 08:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •