Results 1 to 4 of 4

Thread: 2006 rxp

  1. #1

    2006 rxp

    hi guys out my ski today.. it went into limp mode and there is oil in the hull. it runs so cant be engine. im thinking oil pipe. any ideas. thx


  2. #2
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,653
    +1
    508
    check the drive shaft seal/bearing on the engine

  3. #3
    if its that is it and easy change.. pump off carbon ring and seal off does the knew one just push in. thx..

  4. #4
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,653
    +1
    508
    factory had a Oetiker clamp
    but a narrow worm gear will also work

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2006 RXP only goes 4 MPH....
    By alib121185 in forum 4-Tec Performance
    Replies: 14
    Last Post: 07-04-2008, 02:14 PM
  2. 2006 Rxp
    By Nitro4Life in forum 4-Tec Performance
    Replies: 7
    Last Post: 06-26-2006, 10:44 AM
  3. 2006 RXP WHATS NEXT
    By DANNYA09 in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-31-2006, 11:50 AM
  4. 2006 RXP...MUCH faster than I though!!!
    By ramnj in forum 4-Tec Performance
    Replies: 30
    Last Post: 04-18-2006, 02:22 AM
  5. 2006 RXP
    By ActionR32 in forum 4-Tec Performance
    Replies: 7
    Last Post: 10-04-2005, 11:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •