Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    coreyallen's Avatar
    Join Date
    Jun 2014
    Location
    Jacksonville Fl
    Posts
    57
    +1
    1

    4-tec oil sensor question

    I just took off my rear oil sensor because I been getting the check engine light come on like everyone else and decided to replace it. When I unscrewed it green coolant poured out. Is this normal for coolant to be pouring out of a oil sensor hole?


  2. #2
    Vern's Avatar
    Join Date
    May 2005
    Location
    Grand Haven, MI
    Posts
    3,594
    +1
    128
    No ... If you saw green coolant come out, I would think you unscrewed the wrong sensor. The oil sensor is down under the intake manifold and you need to remove the intake manifold to get at it. Is that the one you removed?

  3. #3
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,964
    +1
    2,767
    Quote Originally Posted by coreyallen View Post
    I just took off my rear oil sensor because I been getting the check engine light come on like everyone else and decided to replace it. When I unscrewed it green coolant poured out. Is this normal for coolant to be pouring out of a oil sensor hole?
    You unscrewed the engine temp sensor

  4. #4
    coreyallen's Avatar
    Join Date
    Jun 2014
    Location
    Jacksonville Fl
    Posts
    57
    +1
    1



    Ye because some dipsht had this pic up. That sensor is gonna be hard to get off is there a thread on here explaining how to

  5. #5
    coreyallen's Avatar
    Join Date
    Jun 2014
    Location
    Jacksonville Fl
    Posts
    57
    +1
    1
    Looks like Im gonna hafta take the throttle body off oh joy screw these damn seadoos I shoulda bought a boat. Id like to punch the guy in the face who sold me this.

  6. #6
    brendanm's Avatar
    Join Date
    Jan 2013
    Location
    Gold Coast, Australia
    Posts
    747
    +1
    149
    Rear oil sensor is easy on your ski, don't have to pull the intake manifold if you don't want to, use 3/8 ratchet, decent extension and deep socket.

  7. #7
    FPV TRANNY's Avatar
    Join Date
    Mar 2015
    Location
    Gold Coast, Australia
    Posts
    247
    +1
    36
    Quote Originally Posted by coreyallen View Post
    Looks like Im gonna hafta take the throttle body off oh joy screw these damn seadoos I shoulda bought a boat. Id like to punch the guy in the face who sold me this.
    Ha ha. You sound like me..lol
    Keep the faith mate. These Seadoos can be a pain in the arse but Gowd the fun when there going

  8. #8
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,653
    +1
    508
    intake mani remove and replace is one of the easiest jobs to do
    try the exhaust mani if you want to cuss at brp

  9. +1 by:


  10. #9
    g550plt's Avatar
    Join Date
    May 2013
    Location
    Boynton Beach, FL
    Posts
    130
    I was able to get that sensor out no problem by simply removing throttle body.. No need to take off intake

  11. #10
    coreyallen's Avatar
    Join Date
    Jun 2014
    Location
    Jacksonville Fl
    Posts
    57
    +1
    1
    I just got my "new" sensor in the mail and it has white stuff on the grooves. I dont think they come with already applied loctite or some other form of sealant so Im wondering if the fuckers sold me a used oil sensor. I got it from 2wheelpros and now Im reading alot of bad reviews of them. I already emailed them about taking so long to mail it and they said to shop somewhere else net time

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 8
    Last Post: 07-22-2013, 02:56 PM
  2. 4tec oil sensor part number question
    By jekvall in forum 4-Tec Performance
    Replies: 2
    Last Post: 06-11-2010, 12:19 PM
  3. Sea Doo 4 Tec Oil Questions - Please Educate Me
    By seatsR4toilets in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 03-20-2010, 10:30 AM
  4. Oil sensor question
    By awd98tsi in forum 2-Stroke Performance
    Replies: 1
    Last Post: 07-02-2009, 10:35 AM
  5. 4 Tec Oil Pump Question
    By JeffSki in forum 4-Tec Performance
    Replies: 1
    Last Post: 11-04-2008, 05:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •