Results 1 to 4 of 4
  1. #1

    Repeated "Check Engine" as I speed up thru about 25 MPH 2004 GTX 4tec

    Ski starts and runs fine, but as I accellerate at about 25 - 28 mph, repeatedly engine seems to do a split second hesitation at about 27 mph and I get "check engine". Runs right on up to 65 mph and runs like a top. Shut off and restart and no code until speeding up to about 27 mph. Anybody have and idea? I changed Throttle Position Switch just in case, but didn't stop the problem.


  2. #2
    Have you tried pulling the code when the check engine light comes on?

  3. #3
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,453
    +1
    182
    Press the set button 5 times when it happens.

    It will come on by rpms not speed. Probably around 3500 rpms

  4. #4

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 4-Stroke NY Fzr project. Trying to get as much speed out of fzr without engine mods
    By Champion Ed FZR in forum Yamaha Projects & Build Threads
    Replies: 38
    Last Post: 07-05-2012, 09:35 AM
  2. Check Engine O.T.A.S. lights ON..... 2011 RXTX As. Anyone?
    By coachfarnen in forum 4-Tec Performance
    Replies: 8
    Last Post: 06-02-2011, 08:54 PM
  3. check engine light came on when i went down to sea level
    By macattack in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-01-2005, 02:00 PM
  4. Check Engine Light
    By meeper in forum 4-Tec Performance
    Replies: 6
    Last Post: 07-27-2005, 04:24 PM
  5. Getting "Check Engine" message on 04 RXP
    By Jrsrxp in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-20-2005, 01:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •