Page 1 of 2 12 LastLast
Results 1 to 10 of 14
  1. #1
    DoubleTap's Avatar
    Join Date
    Jun 2011
    Location
    Fort Myers, FL
    Posts
    242
    +1
    71

    Help 2015 FX SHO top speed issue

    My 15 SHO use to run 69-70 on gps. Now it only runs 62-63 on gps?
    It has 64 hours
    It's at Yamaha now and they can't find the problem.
    Plugs were replaced. They said compression, fuel pressure,coils,fuel,jet pump, is all good?
    What else can it be? The ski doesn't miss or run funny, it's just down on power.


  2. #2
    WP3223's Avatar
    Join Date
    Jun 2011
    Location
    Boynton Beach, FL
    Posts
    895
    +1
    93
    Boost leak @ WOT, or Throttle body dampener might be worth checking out.

  3. +1 by:


  4. #3
    boost hose! pop the seat, start it, stick your head down there and pop the throttle- you will probably feel air in the face

    also any dealer that cannot fix a problem on a 15 ski should be called out on this forum

  5. #4
    DoubleTap's Avatar
    Join Date
    Jun 2011
    Location
    Fort Myers, FL
    Posts
    242
    +1
    71
    Thanks guys!
    I just called them they said no boost leak?

  6. #5
    Quote Originally Posted by DoubleTap View Post
    Thanks guys!
    I just called them they said no boost leak?
    man I really think it is a boost leak... I would go up there and open the seat and check it myself- if it is a boost leak I would shame them and call Yamaha. I'm smelling bs though, I feel like they are not even looking at your ski but I could be wrong

  7. #6
    DoubleTap's Avatar
    Join Date
    Jun 2011
    Location
    Fort Myers, FL
    Posts
    242
    +1
    71
    Unfortunately, right now I'm just going by what they tell me.
    You think they would be able to figure this out in a few hours.
    I mention to them about the Throttle body too.
    Could it be the supercharger clutch slipping?
    Is there any way they can get a boost reading?

  8. #7
    zone5's Avatar
    Join Date
    Feb 2013
    Location
    West of Blue Mountains, Australia
    Posts
    373
    +1
    36
    Check the clamps, in my experience with both forced induction ski's they tend to loosen and leak air as the hose softens when hot.

    Use an 8mm socket on a small ratchet drive, TAPE the socket to it so it doesn't come off and get lost, keep it in the glove box. You have to tighten by feel mostly, careful not to snap a clamp. For the first 20 hrs I used to do it regularly, now the the hoses have been compressed enough it seems to have stopped doing it. The J-Pipe can be a real culprit, there is distinct "feel" (pop?) when it's back in place on the throttle body....

  9. #8
    Chelle's Avatar
    Join Date
    Oct 2008
    Location
    Belgium
    Posts
    252
    +1
    7
    Quote Originally Posted by WP3223 View Post
    Boost leak @ WOT, or Throttle body dampener might be worth checking out.
    Same thing happened to me last month @ 35 hours. Iff you put Some presure on the Tb while starting the engine Will not start. Then you know...

  10. #9
    DoubleTap's Avatar
    Join Date
    Jun 2011
    Location
    Fort Myers, FL
    Posts
    242
    +1
    71
    What is the throttle body dampener?

  11. #10
    WP3223's Avatar
    Join Date
    Jun 2011
    Location
    Boynton Beach, FL
    Posts
    895
    +1
    93


    The pic is from Leendart's build. The newer one's can sometimes come loose & vent boost under pressure. I believe most have been replacing them with the newer VXR p/n to fix the issue.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2014 (25hrs) Fx SHO Top speed
    By Toobold in forum Yamaha PWC Performance (4-stroke)
    Replies: 7
    Last Post: 07-30-2016, 04:19 PM
  2. 2015 VX Cruiser Top Speed issue
    By carbon in forum Yamaha PWC Performance (4-stroke)
    Replies: 17
    Last Post: 04-14-2016, 02:22 PM
  3. 2009 Fx sho top speed?
    By dijsil in forum Yamaha PWC Performance (4-stroke)
    Replies: 5
    Last Post: 10-26-2014, 11:32 AM
  4. 2009 FX SHO: Top speed issue
    By kur1j in forum Yamaha PWC Performance (4-stroke)
    Replies: 4
    Last Post: 06-23-2014, 10:50 PM
  5. Fx sho top speed
    By shotime2 in forum Yamaha PWC Performance (4-stroke)
    Replies: 6
    Last Post: 09-14-2009, 06:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •