Results 1 to 7 of 7
  1. #1
    Jose12889's Avatar
    Join Date
    Apr 2015
    Location
    Buffalo Ny
    Posts
    29

    bad sending unit help

    Any one knows a way to fix the sending unit or buy a replacement genesis 03 fuel pump is good .

    It is fuel injected so is the one piece pump thanks


  2. #2
    MSX 150 guy lives on Mr. GP1800's Avatar
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    17,414
    +1
    1,476
    Have you checked it with an ohm meter?

    I think the next step would be to pull the fuel pump and test the sender with an ohm meter connected, move the float up and down.
    Last edited by K447; 05-19-2015 at 10:03 PM.

  3. #3
    Jose12889's Avatar
    Join Date
    Apr 2015
    Location
    Buffalo Ny
    Posts
    29
    OK so I filled it up before riding did not went to full on display Took the ski on the water while having fun with it jumping etc.... starting to say full the next day removed the seat it was not full was almost empty

  4. #4
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    39,202
    +1
    1,716
    Quote Originally Posted by Jose12889 View Post
    OK so I filled it up before riding did not went to full on display Took the ski on the water while having fun with it jumping etc.... starting to say full the next day removed the seat it was not full was almost empty
    This is a Ficht fuel injected engine, correct?

    That means the fuel pump should be removed in order to reinforce the mounting of the fuel pressure regulator which is located inside the fuel pump body. It is common for the regulator to work loose and fall off inside the fuel pump, which creates a low fuel pressure in the injectors and can damage the engine from lean burn.

    Since the fuel pump must be removed to repair the regulator (which should be done even if it has not yet failed) you can also inspect and test the fuel level sender. Note that the sender is a simple float on an arm. If the arm has become bent then it may be getting hung up rather than freely moving with the fuel level. When removing the fuel pump take care not to snag the fuel float and arm as you extract the pump from the fuel tank opening.

    See my signature links for more info on the Ficht fuel pump and the reinforcement repair of the fuel pressure regulator.

  5. #5
    Jose12889's Avatar
    Join Date
    Apr 2015
    Location
    Buffalo Ny
    Posts
    29
    Bought the ski at first not running bad ecu got that fixed the it didn't want to accelerate took the pump out regulator fallen then in the water it was misfiring put new plugs nothing changed the tps problem solved did few of the basics

  6. #6
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    39,202
    +1
    1,716
    Quote Originally Posted by Jose12889 View Post
    Bought the ski at first not running bad ecu got that fixed the it didn't want to accelerate took the pump out regulator fallen then in the water it was misfiring put new plugs nothing changed the tps problem solved did few of the basics
    Perhaps the level sender arm was snagged when the pump came out or went back in. It is important to orient the fuel pump while inserting into the tank so the float is facing the rear of the hull.

    When I did my own that meant the Ficht fuel pump body was inserted part way into the tank opening, then rotated the float arm into position, then lowered the rest of the way.

  7. #7
    Jose12889's Avatar
    Join Date
    Apr 2015
    Location
    Buffalo Ny
    Posts
    29
    I'll check I'm sure is put on right . On another subject quickly is it worth upgrading the impeller to a Solas 15/21

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2006 STX 12F Fuel level sending unit....HELP!
    By Lucrative in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 02-23-2015, 07:08 PM
  2. Fuel sending unit help
    By Tormented in forum 2-Stroke Performance
    Replies: 16
    Last Post: 04-21-2014, 12:51 AM
  3. 01 gpr need help quick with fuel sending unit issue
    By silvercrxsir in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 08-06-2012, 02:12 AM
  4. maybe a sending unit gone bad??
    By mudd in forum Polaris Open Discussion
    Replies: 9
    Last Post: 08-08-2007, 10:12 PM
  5. gas gauge? sending unit? i need some help
    By juggaloXPracer in forum 2-Stroke Performance
    Replies: 1
    Last Post: 06-21-2007, 05:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •