Results 1 to 9 of 9
  1. #1
    seawave's Avatar
    Join Date
    Sep 2013
    Location
    Ontario
    Posts
    39
    +1
    9

    Help with check engine light and IBR light

    My ski a 2013 155. threw to codes and went into limp mode yesterday P1106, C2111. shut it down and waited five mintues and the codes were cleared and I thought it was good to go. Then I wasn't going to fast maybe 40, let off the throttle and I heard and felt a clunk in the pump area and same codes can on again. I was making a clunk/vibrating Nosie every few seconds of me going slow to shore. shut it down reset it and ski preformed perfectly again for the rest of the day.

    So the first summer I had it threw these to codes once and I got bummed cause the ski only had 18 hours on it but it rest itself and its been fine since.


    ski now has 221 hours on it. any thoughts or should I just take it to the dealer? the ski is working like new now though again


  2. #2
    Sturm215's Avatar
    Join Date
    May 2010
    Location
    Lakeland florida
    Posts
    1,892
    +1
    64
    Sometimes small sticks or trash can float into the pump tunnel sitting still and get wedged in the IBr brackets.

  3. +1 by:


  4. #3
    seawave's Avatar
    Join Date
    Sep 2013
    Location
    Ontario
    Posts
    39
    +1
    9
    took it out yesterday and put another 2 hours on it, preformed perfectly . must have been something in there like you said.

  5. +1 by:


  6. #4
    formula29's Avatar
    Join Date
    Feb 2014
    Location
    Ormond Beach
    Posts
    139
    +1
    10
    I had a simular problem on my xt, while on the lake cruising the ibr light came on and reduced power, I shut off the ski and restarted it and everything was fine, the next day at home in the garage I hit the override button and lifted the bucket and thats all she wrote, it would not move again and I had ibr light on and a fault code of c2115, I hope yours keeps working for you, I just ordered a new ibr at the cost of 1,000 dollar's, I hear their is also a software update for them as well to fix some issues,

  7. #5
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    9,986
    +1
    2,636
    get a good light in there and look for a control arm broken and wedged in there.( could be the port side one)

    be warned it's a huge pain to get one of these apart when the bucket is wedged. huge

  8. #6
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    Friendswood, Texas
    Posts
    8,870
    +1
    625
    Quote Originally Posted by formula29 View Post
    I had a simular problem on my xt, while on the lake cruising the ibr light came on and reduced power, I shut off the ski and restarted it and everything was fine, the next day at home in the garage I hit the override button and lifted the bucket and thats all she wrote, it would not move again and I had ibr light on and a fault code of c2115, I hope yours keeps working for you, I just ordered a new ibr at the cost of 1,000 dollar's, I hear their is also a software update for them as well to fix some issues,
    I have the capability to perform the software updates to the ibr, would you mind sending me the broken unit so I can see if the update fixes it?

    I was experiencing IBR issues and the gate wouldn't move, left me stranded in N, ended up being a faulty stater solenoid not fully engaging and screwing with the electrical. who knew

  9. #7
    Full Throttle or Broke!!! UNSANE's Avatar
    Join Date
    Aug 2008
    Location
    Orlando
    Posts
    722
    +1
    82
    They are very touchy systems. I had constant IBR problems, even after the system was replaced 3 times. It was constantly throwing IBR sensor codes and would act up after hitting any small/medium wake. Turned out I had a bad harness. New harness and all is well now.

  10. #8
    seawave's Avatar
    Join Date
    Sep 2013
    Location
    Ontario
    Posts
    39
    +1
    9
    Just an update I case somebody later on is reading this. Got a good light I checked everything out nothing is snapped or anything. Put another 4 hours on it yesterday preformed fine. thanks for the help everyone

  11. #9
    jeteffect's Avatar
    Join Date
    Feb 2011
    Location
    Canada
    Posts
    437
    +1
    12
    Quote Originally Posted by seawave View Post
    Just an update I case somebody later on is reading this. Got a good light I checked everything out nothing is snapped or anything. Put another 4 hours on it yesterday preformed fine. thanks for the help everyone
    Good stuff

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 11
    Last Post: 10-23-2019, 12:28 AM
  2. help with check engine light
    By kbolaloco1 in forum 4-Tec Performance
    Replies: 8
    Last Post: 04-02-2013, 11:29 AM
  3. MSX 150 6000rpm max with check engine light
    By Hinchi in forum MSX/Matrix
    Replies: 8
    Last Post: 03-05-2011, 01:12 AM
  4. Help, Check Engine Light, Error Code P0344
    By JC7727 in forum 4-Tec Performance
    Replies: 3
    Last Post: 08-14-2007, 06:27 PM
  5. Check engine light! Not pulling a code... HELP!!
    By Venator in forum 4-Tec Performance
    Replies: 10
    Last Post: 12-10-2006, 07:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •