Results 1 to 9 of 9
  1. #1

    Join Date
    Sep 2011
    Location
    Boca Raton, FL
    Posts
    22

    Need Help, Wont CRANK!

    I have a 2008 RXPX, About 3 Months ago i decide to pull the supercharger and sent it out to get rebuilt. I have about 120 hours on the ski. I put everything back together and got a new battery in. Today when i went to start it wouldnt crank over so i jumped the solenoid and it fired right up. I went out and bough a new one and still having the same problem. i pulled the relay and it checked out good. i also tested the switch and it seems to be working. when i put key in i get one loud beep and then about 10 seconds i get 2 short quick beeps. could of the ecu went bad or reset cause it sat for 3 months without a battery

    Thanks


  2. #2
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    7,437
    +1
    1,766
    I recall hearing about something of this nature for depth finders and vts, but not for a key

    clean the post and inside of the key with a clean cloth, have any other keys?..long beep is rejection, two beeps are "hey they key is on and the engine isn't running"

  3. #3
    SplishSplash's Avatar
    Join Date
    May 2006
    Location
    Belle River Ont Canada
    Posts
    1,376
    +1
    128
    Are you sure your using the right key? I have the battery disconnected for 6 months at a time every year for 15 years and it never forgot the key.
    One long beep is its not seeing the key correctly, clean the post, try disconnecting and reconnecting the battery. All else fails it going to need to be connected and key programmed.

  4. #4

    Join Date
    Sep 2011
    Location
    Boca Raton, FL
    Posts
    22
    The Post and key is clean... heres a video on trying to start i relay and solenoid don't make a sound the only sound i head sounds like fuel pump priming. i ran the ski tonight on the hose and it ran great but i have to jump solenoid to start


  5. #5
    captain slow Turbo Retro's Avatar
    Join Date
    Jun 2007
    Location
    Australia - perth
    Posts
    1,683
    +1
    164
    you bought a new starter relay and replaced it???
    have u got a voltmeter?? you need to measure whether the ecu is trying to turn the starter relay on. just fixed a rxtx with this problem.

  6. #6
    SplishSplash's Avatar
    Join Date
    May 2006
    Location
    Belle River Ont Canada
    Posts
    1,376
    +1
    128
    "I get 1 Loud Beep" says it all, no need to replace starters or relays or check voltages, until he gets BEEP BEEP when he puts on the key, its not going to start with the stop/start button.
    This is a key/Dess/ECU issue. But Check your fuses and did you disconnect and reconnect your battery.

  7. #7
    captain slow Turbo Retro's Avatar
    Join Date
    Jun 2007
    Location
    Australia - perth
    Posts
    1,683
    +1
    164
    Quote Originally Posted by SplishSplash View Post
    "I get 1 Loud Beep" says it all, no need to replace starters or relays or check voltages, until he gets BEEP BEEP when he puts on the key, its not going to start with the stop/start button.
    This is a key/Dess/ECU issue. But Check your fuses and did you disconnect and reconnect your battery.
    my rxt makes the same noise before it starts. 4 beeps after means its ready to go.

  8. #8
    SplishSplash's Avatar
    Join Date
    May 2006
    Location
    Belle River Ont Canada
    Posts
    1,376
    +1
    128
    OK, Beep Beep Beep Beep, which he is not getting. Same end result

  9. #9
    captain slow Turbo Retro's Avatar
    Join Date
    Jun 2007
    Location
    Australia - perth
    Posts
    1,683
    +1
    164
    Quote Originally Posted by SplishSplash View Post
    OK, Beep Beep Beep Beep, which he is not getting. Same end result
    have you watched the video he posted?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Yamaha fzs wont crank need help
    By AmishFZS in forum Yamaha PWC Performance (4-stroke)
    Replies: 24
    Last Post: 03-31-2014, 03:34 PM
  2. Need Help! GP1200R Crank? issues?
    By NeVerMind in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 08-23-2010, 11:21 AM
  3. need help wont start
    By asia517 in forum Yamaha Old School Skis
    Replies: 9
    Last Post: 08-31-2007, 08:14 AM
  4. XLT1200 I need help, wont start...
    By GeoRXT in forum Yamaha PWC Performance (2-stroke)
    Replies: 15
    Last Post: 07-29-2007, 01:49 PM
  5. need help!! 2004 rxp no beep no crank
    By shannon in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 07-06-2007, 01:10 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •