Results 1 to 8 of 8
  1. #1
    Ale's Avatar
    Join Date
    Feb 2014
    Location
    ITALY
    Posts
    839
    +1
    61

    again... few questions on the FZ SHO platform...

    men...
    I have few questions...

    1) have R&D program steering limiter like oem ecu?
    2) how many rpm is this limiter?
    3) how can I bypass this sensor?

    I think I have an issue with this sensor...
    sometimes ski go only 6000 rpm, like a learning mode or a limited mode...
    like reverse but higher rpm.

    today I tought a hose from intercooler to throttle body...
    but after a minute all comes normal again...
    I think is a electrical sensor/problem.

    no error code on dash
    boost stop at zero
    afr is normal
    rpm max 6000
    no strange sound (like something in impeller/pump)

    thanks
    Ale


  2. #2

    Join Date
    Mar 2010
    Location
    the moon
    Posts
    862
    +1
    19
    check your clutch first.

  3. +1 by:

    Ale

  4. #3
    Ale's Avatar
    Join Date
    Feb 2014
    Location
    ITALY
    Posts
    839
    +1
    61
    Think clutch is ok.
    driving it.... it feel like an electrical limiter

  5. #4
    Ale's Avatar
    Join Date
    Feb 2014
    Location
    ITALY
    Posts
    839
    +1
    61
    no one same issue?

  6. #5
    Ale's Avatar
    Join Date
    Feb 2014
    Location
    ITALY
    Posts
    839
    +1
    61
    was the clutch.... .....

  7. #6
    badjoka's Avatar
    Join Date
    Jun 2009
    Location
    Fairfield, CT
    Posts
    1,498
    +1
    137
    Guess thats good news, at least the problem is found. Still having the spike of RPMS?

  8. #7
    Ale's Avatar
    Join Date
    Feb 2014
    Location
    ITALY
    Posts
    839
    +1
    61
    NO...
    it was a totally different problem ! !

  9. #8
    Have you gone through every hose clamp with a 1/4 ratchet and tightened them all down again? Seems like s boost leak. Lots of connections and lots of places for air to come or go.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. A few questions on the yamaha 64x
    By amk in forum Yamaha Old School Skis
    Replies: 7
    Last Post: 03-25-2015, 04:37 PM
  2. Few questions on 2010 fx sho.
    By Chaseyb093 in forum Yamaha PWC Performance (4-stroke)
    Replies: 8
    Last Post: 05-08-2014, 10:19 PM
  3. Question on R&D SHO/FZ Surge Protector Kit
    By 64physhy in forum Yamaha PWC Performance (4-stroke)
    Replies: 4
    Last Post: 08-25-2010, 11:10 AM
  4. Few questions on my slx after the first few times out.
    By ryanbgb22 in forum Polaris Open Discussion
    Replies: 7
    Last Post: 05-23-2010, 09:31 AM
  5. Two Questions On The SHO...
    By MiamiDave in forum Yamaha PWC Performance (4-stroke)
    Replies: 13
    Last Post: 08-12-2008, 12:29 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •