Results 1 to 4 of 4
  1. #1

    01 Genesis No spark

    I've been working on a friends ski and Now I'm completely stumped.
    Here's the cliff notes.
    replaced stator, voltage regulator and CDI still have no spark. New AGM battery full charge and voltage never drops below 11.3 while cranking.
    Where do I look now?


  2. #2
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    39,214
    +1
    1,720
    Welcome

    Bypass the LR-505 Start/Stop module.

    Hold down the Bilge button while cranking, see if it has spark and starts.

  3. #3
    I've tried that too.

  4. #4
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    39,214
    +1
    1,720
    Quote Originally Posted by Bama Ski View Post
    I've tried that too.
    Put voltmeter probes right at the CDI ground and power input wires. Verify that the required battery voltage is actually reaching the CDI (greater than 10.6 volts while cranking).

    If that is correct then review every ground and wire connection. Look for possible incorrect wire connections at the terminal board, and the electrical box grounding links. Confirm that the electrical box ground is indeed zero ohms to the engine case.

    Check ignition coil ground connection at CDI.

    Disconnect the ignition kill wire at the CDI.

    Disconnect the stator wires and confirm correct ohms on exciter coil.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 genesis NO SPARK QUESTION FLYWHEEL MAGNETS?
    By greg.p in forum Polaris Open Discussion
    Replies: 3
    Last Post: 08-25-2010, 10:38 PM
  2. Genesis, no spark...
    By jetskitokey in forum Polaris How To & FAQs
    Replies: 8
    Last Post: 08-12-2009, 05:20 PM
  3. 96 slt700 poss. 01 motor? no spark
    By papa joe in forum Polaris PWC Performance
    Replies: 3
    Last Post: 07-28-2009, 08:46 AM
  4. 2001 Genesis no-spark, no-fuel
    By chev-hell in forum Polaris Open Discussion
    Replies: 9
    Last Post: 09-24-2007, 04:50 PM
  5. 99 Genesis - no spark??
    By misplaced in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 08-28-2007, 11:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •