Page 8 of 8 FirstFirst ... 678
Results 71 to 80 of 80

Thread: Thar She Blows

  1. #71
    SeaLion's Avatar
    Join Date
    Aug 2006
    Location
    Ride Mohave To Havasu.
    Posts
    860
    +1
    3
    Quote Originally Posted by beerdart View Post
    Yes one nut at a time no need to pull the head. McMaster has the washers and o-rings.
    Will the solid copper washers I found work or don't even waste time with it?


  2. #72
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,991
    +1
    1,421
    Yes they should work fine.
    Quote Originally Posted by SeaLion View Post
    Will the solid copper washers I found work or don't even waste time with it?

  3. #73
    SeaLion's Avatar
    Join Date
    Aug 2006
    Location
    Ride Mohave To Havasu.
    Posts
    860
    +1
    3
    Put em on last night when I got home from rocking in Cali and as I was wrenching on it I felt the 7.1 in my AZ garage. I'm going to wait til Sunday afternoon once the Holiday crazies are off the water to take it out and see if it still squirts. I temporarily put some of the super strong flex seal tape on the hull to pump housing crack so no water seeps in there. That stuff sealed a 9" crack in my bathtub so I know it works well and doesn't peel off and keeps water out.

  4. #74
    SeaLion's Avatar
    Join Date
    Aug 2006
    Location
    Ride Mohave To Havasu.
    Posts
    860
    +1
    3
    Quick update. Making progress. I tested it on the trailer in the water today before having to head back to Cali for work. No more leaking around the nut base but I had one nut on each head dribble a little bit of water through the threads and top of the nuts now. At least it's not squirting and streaming out. I removed those three nuts and put some loctite 518 anaerobic sealant I have that I use on the oring and put it around the stud and on the threads and torqued em back. I'll see if that seals them when I get back home again later in the week. It will have plenty of time to dry.

  5. #75
    SeaLion's Avatar
    Join Date
    Aug 2006
    Location
    Ride Mohave To Havasu.
    Posts
    860
    +1
    3
    Burned a 1/2 tank through it this afternoon and most of it at WOT. According to the MFD I rode 14 miles, max rpm was 6950 and max speed 58.9mph. Air temp was 114*. No leak around any of the head nuts or threads. My flex seal tape held up great on the hull not letting water through. Had a little water in the hull but acceptable. Not enough for the bilge pump to ever have to pump out. One guy after seeing me ride it came up to me and asked if I want to sell it? He was a local PWC mechanic and he really liked what he saw and commented what I was running in that thing cause it was looking and sounding good on the water. I told him it's not for sale. We talked for a little bit and he was in the middle of a vintage 650SX build and I mentioned I have one along with an X-2 and immediately he asked if I want to sell my X-2. I said over my dead body LOL.

    So to put an end to the mystery ball ,I think the ski was fine all along and something was in the case since day one that finally made it's way into the combustion chamber, bounced around, smashed the plug gap and stalled the ski. I saw the smashed plug and thought the worst of some kind of catastrophic failure. Life got in the way and it sat for 14 years and now it's back to its glory days. What a journey! Thanks to all who participated in this thread. The beast lives on!!! Would be cool if Randy and Al saw this finale.

  6. #76
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,599
    +1
    51
    Thanks for the closure SL.

    This set up always had me interested. I still have all the parts to make it work laying around the house.

    Glad to hear she's back up and running. There was another guy a while ago that decided to attempt this configuration as well. He must have gotten it right because had a similar story of a guy seeing him ride it and asked if it was for sale too. He did sell his though, for a nice profit i believe.

    Not sure where Al has been any more? He sold a Matrix to Pirate

    Amsoil Kevin used to peek in every now and again.

    Randy is now at http://weberpower.com/ if you want to drop him a line. I spoke to him early in the season.

    John Zigler from Rock County now owns Watcon.

    Congrats on the ski and enjoy it.

  7. #77
    SeaLion's Avatar
    Join Date
    Aug 2006
    Location
    Ride Mohave To Havasu.
    Posts
    860
    +1
    3
    You should build it if you have the parts. Ran mine again yesterday but seat and tray time was spread between the SJ, X-2 and SLX. Seems to be running a little rich. I thought it would clear up once a tank was ran through it from residual oil from evaporated fuel while it sat. My son is too gentle with it and it loads up for him. I told him you gotta be on the throttle and not baby it LOL. Fuels of today are not like the fuels of 14 years ago. I don't know if I lost my AAT internals or if it is removed and I put it somewhere but there is no internal in it and I just noticed that. I can't recall if it could be run without the internals?

  8. #78
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,599
    +1
    51
    I would think you'd lose top end with no shuttle installed.

  9. #79
    SeaLion's Avatar
    Join Date
    Aug 2006
    Location
    Ride Mohave To Havasu.
    Posts
    860
    +1
    3
    I don't know if I removed it to test or if it fell off and I lost it. I'm not too concerned with top speed but that low and mid punch it has is what I'm loving. My sons are riding it for the launch factor. I just made sure to tell them to let off the throttle when in the air lol. Still running great. I found a freebie SL 700 hull that I picked up to remove whatever I could salvage from it. I got the start switch, stop switch with trim adjuster, trim motor, steering cable, throttle cable, water/fuel separator, bunch of straps, took all the screws and bolts I could get off of it, seat catch and latch, it has a gas tank but I don't know if I want to store that, stock pipe and waterbox from the 700 that I don't need. I'm not going to keep the hull. I planned to cut it up and trash it. It's in good shape but I don't want to store it. If someone wants a 2 seater hull let me know. It didn't have a title. It was given to the guy I got it from too. No engine or E box in it.

  10. #80
    SeaLion's Avatar
    Join Date
    Aug 2006
    Location
    Ride Mohave To Havasu.
    Posts
    860
    +1
    3
    Almost forgot. My hood latch catch broke in half last week and that is why I wanted that free hull when I saw it on Craigslist. Unfortunately the latch catch on that one was split in half the same way mine split. I super glued both and put a zip tie around the round part and clamped them overnight. It didn't break apart yet. I'm going to leave the zip tie around it and maybe even cut a small groove around the circumference and put a wire around it or a hose clamp. It should keep it functional still. I doubt Polaris has that part still available so this could be a fix for others too. Have yet to water test to see if it holds together but with the wire or hose clamp wrap, it should.

Page 8 of 8 FirstFirst ... 678

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. THAR SHE BLOWS!!! (piston)
    By rlovebk in forum Polaris Open Discussion
    Replies: 113
    Last Post: 08-10-2009, 11:27 PM
  2. Scion tC Blows motor on highway doin 130
    By Shibby1485 in forum Sea Doo Open Discussion
    Replies: 20
    Last Post: 11-18-2005, 09:05 AM
  3. RIVA SD Supercharger Blow-off Valve Kit an urgent question
    By amirmiz in forum 4-Tec Performance
    Replies: 2
    Last Post: 11-04-2005, 09:25 AM
  4. Detail Blow of Valve instructions Please
    By TroyRXP15 in forum 4-Tec Performance
    Replies: 16
    Last Post: 08-11-2005, 01:54 PM
  5. blow off valve question
    By TroyRXP15 in forum 4-Tec Performance
    Replies: 8
    Last Post: 07-21-2005, 02:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •