Page 6 of 8 FirstFirst ... 45678 LastLast
Results 51 to 60 of 80

Thread: Thar She Blows

  1. #51
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,991
    +1
    1,419
    Long time no talk good to see your still around.


  2. #52
    SeaLion's Avatar
    Join Date
    Aug 2006
    Location
    Ride Mohave To Havasu.
    Posts
    860
    +1
    3
    Quote Originally Posted by beerdart View Post
    Long time no talk good to see your still around.
    Yes it's been awhile. Great to hear from you. I just ordered a base gasket and exhaust manifold gasket and plan to put it back together and run it. Fuel lines are all dried out so I'm going to replace that too. Washed off all the dust today and I got all nostalgic looking at it. It's a nice looking ski and light compared to the behemoths of today I see out on the water. Those are not for me. I'm going to get some front tubbies for my X-2. It's still my favorite ski to ride.

  3. #53
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,590
    +1
    49
    When I was still riding a 2 seater 780 a few years back a little kid told his dad, "look dad, a mini jet ski". I just laughed, but you're right. They are big boats now.

    If you're going to replace the fuel lines, might as well open up the carbs too. Might have some serious varnish going on inside by now. And while you're in there, please post up your jetting specs too. i was always curious to know what you had while running the 44's on that engine.

    I have a 92 pipe, 785 CDI, and 44mm carbs still sitting here because I was always curious to try that set up out.

  4. #54
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,729
    +1
    96
    It. Is. Aliiiiiiive.

  5. #55
    SeaLion's Avatar
    Join Date
    Aug 2006
    Location
    Ride Mohave To Havasu.
    Posts
    860
    +1
    3
    Hey Mark!

    Okay it's all back together and it fired right up. My mfd is dead though. It worked when it got garaged but oh well. Someone refresh my memory. Is there a restrictor needed in one of the fuel lines or the Pro 785 carbs I have on there don't need it? I should know this but it's been too long. I put all new fuel lines and it just popped in my head about the restrictor.

    I have also come to the conclusion that something must have been in the bottom end this whole time and finally got sucked up a transfer port maybe from the kid bouncing it straight up and down for 15 minutes. I'll see if it stays together once riding it but it's running on the hose just fine.

  6. +1 by:


  7. #56
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,590
    +1
    49
    Many of the MFD display's are repaired by cutting them open and just cleaning the internal contacts. If yours is not working check the fuse first.

    No restrictor in the 780 or Pro 785 carbs needed. Already built in. Only the 650 and 750 used the in-line one.

  8. #57
    SeaLion's Avatar
    Join Date
    Aug 2006
    Location
    Ride Mohave To Havasu.
    Posts
    860
    +1
    3
    The gauge had some bars on the lcd so I'm assuming the fuse is fine. It probably has the bad contacts. Yes now I remember the restrictor deal. I used to have an SL750 and that one had it. Been way too long.

    Took it to the ramp to just fire up on the trailer and run it like that. I had water leaking around some of the head studs/nuts. I torqued to 18 ft lbs. but my head is modified with cut stock gasket for the water passages sealing and oring for the combustion chamber. Honestly I don't recall the torque specs for my specific mod by HPT-Sport who did it back in the day. George has since sadly passed away. I brought it back home because I didn't take tools with me to the ramp. I torqued them tighter and to 20 ft lbs. Went back and tested again and it got a little better but still a couple of them leaked. Brought it home and took the heads off and couldn't see anything wrong. The oring sealed the combustion chamber so no water gets in there. I cleaned the copper spray off the modified head gaskets and redid it and this time only torqueing to 16 ft lbs. For some reason 16 sticks in my mind. Well that leaked too. Had the tools with me and torqued to 22 ft lbs. Still leaked so I gave up. Revs nicely on the trailer and I held the throttle pretty high for a little bit several times. If it was gonna blow it would have done it. Now I'm pretty convinced the engine is fine and always was and my theory of something being in the reman engine from day one that finally got sucked up from being thrown loose from the kid bouncing it the way he did like a bucking bronco. The last thing I was expecting was the slight water leak around some of the head nuts. The 78 is up and the tab is at the water bar on all of them. The mag and middle had a couple that leaked but the pto which had the bb bouncing was the one not leaking anywhere. You can see in my old pictures what the head mod, o-ring and modified stock gasket looks like. I was expecting a lot to go wrong but this wasn't even a thought to have water oozing a little out of some of the head nuts. Well that's where I'm at. I'm gonna take the heads off again and maybe install the gasket to the head before slipping them both on. I just slid the gaskets on the studs and then dropped the head on it. Something must not be lining up and water getting to the studs and up under the head nuts????

  9. #58
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,590
    +1
    49
    Not sure, never really had water leaking around the studs before.

    Kedanno once found some rubber seal washers that might be worth looking into? It had a rubber seal around the hole in the middle that would seal the stud.

    Other option might be to squeeze some silicone around the studs before installing the nuts?

    Or, are you copper spraying BOTH the heads and the gaskets? Should get some oozing to help seal the water out.

  10. #59
    SeaLion's Avatar
    Join Date
    Aug 2006
    Location
    Ride Mohave To Havasu.
    Posts
    860
    +1
    3
    Oh man I just came in to cool off and just saw this. I just finished redoing it all again but mating the gasket to the head and then slipping it down on the studs all together. I never had to spray the head with the copper spray before. Just both sides of the modified gasket. I lined up the the heads on the studs a little better this time. I noticed that they were all to one side and not in the center of the holes. I never paid attention to that before and never noticed so much play in it. Hopefully this will do it or otherwise it's gonna sit again and I'm just gonna ride the other 5 running skis. Working on a black ski in 113* temps sucks. My garages are packed with stuff from moving. Interesting on the rubber washers. I don't recall this leaking around the studs being an issue before. I had the silicone in my mind too but I don't think this should be leaking and that would be a band aid. If I can get down to the water later I'll give it another trailer run.

  11. #60
    SeaLion's Avatar
    Join Date
    Aug 2006
    Location
    Ride Mohave To Havasu.
    Posts
    860
    +1
    3
    Got it to the ramp and same issue. Still leaking on some head nuts. Back into storage it goes. Too bad because I really wanted to run the 780 beast again. If someone has some stock 780 heads for sale cheap preferably for 1mm overbore I'll take em and run it with stock heads and gaskets. Could the heads have warped just sitting in a hot AZ garage for 14 years. I had them just sitting on the jugs with no nuts on them. I doubt it but with all this weirdness I have been experiencing, I'm not ruling anything out.

Page 6 of 8 FirstFirst ... 45678 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. THAR SHE BLOWS!!! (piston)
    By rlovebk in forum Polaris Open Discussion
    Replies: 113
    Last Post: 08-10-2009, 11:27 PM
  2. Scion tC Blows motor on highway doin 130
    By Shibby1485 in forum Sea Doo Open Discussion
    Replies: 20
    Last Post: 11-18-2005, 09:05 AM
  3. RIVA SD Supercharger Blow-off Valve Kit an urgent question
    By amirmiz in forum 4-Tec Performance
    Replies: 2
    Last Post: 11-04-2005, 09:25 AM
  4. Detail Blow of Valve instructions Please
    By TroyRXP15 in forum 4-Tec Performance
    Replies: 16
    Last Post: 08-11-2005, 01:54 PM
  5. blow off valve question
    By TroyRXP15 in forum 4-Tec Performance
    Replies: 8
    Last Post: 07-21-2005, 02:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •