Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 31
  1. #11
    ripcuda's Avatar
    Join Date
    May 2010
    Location
    Newman Lake, WA
    Posts
    2,530
    +1
    195
    Welcome to GH Zek,
    Unless you can't rev above 3400rpms with forward (not reverse) engaged... then no, your described issue does not sound related to a failing SIFB.

    Please start a new thread and tell us more about your issues like...
    What's the skis history? Was it rolled over? When did it last run right?
    What things have you tried?

    Cheers!


  2. #12
    i will do a full assessment and start a new thread. thanks. You all are great!

  3. #13
    Mike Greenwood's Avatar
    Join Date
    Jun 2015
    Location
    Tulsa, Oklahoma
    Posts
    704
    +1
    57
    This seems to be my issue as well. Ski failed to die after lanyard removed, and would only idle to 3400 during operation. Sent off for new sifb. Hopefully this resolves the issue. Do I still need to take to dealer for DW plug in after I install new sifb?

  4. #14
    ripcuda's Avatar
    Join Date
    May 2010
    Location
    Newman Lake, WA
    Posts
    2,530
    +1
    195
    Hi Mike. With all the SIFB issues I've experienced... simply swapping out the bad for a good and restarting the engine was all it took to get things running right again. Hope it's the same for you.

    Cheers!

  5. #15
    Mike Greenwood's Avatar
    Join Date
    Jun 2015
    Location
    Tulsa, Oklahoma
    Posts
    704
    +1
    57
    This is the same issue I have. Order sifb from Randy. Wondering, is there a protocol for restart of Ecu after installation of said part?

  6. #16
    Mike Greenwood's Avatar
    Join Date
    Jun 2015
    Location
    Tulsa, Oklahoma
    Posts
    704
    +1
    57
    Thanks Ripcuda.. You have been a preacher when it relates to protocol on this unit. I cannot thank you enough. Disregard message I sent. We are new to this digital world of communication so forgive me for sending multiple things.

  7. #17
    ripcuda's Avatar
    Join Date
    May 2010
    Location
    Newman Lake, WA
    Posts
    2,530
    +1
    195
    No worries.

    No procedure needed for SIFB replacement... other than have the ski/engine off when swapping. Upon restart... new SIFB will do its thing.

    Cheers!

  8. #18
    Mike Greenwood's Avatar
    Join Date
    Jun 2015
    Location
    Tulsa, Oklahoma
    Posts
    704
    +1
    57
    All is well. My man Randy!

  9. #19

    Join Date
    May 2015
    Location
    Ocala FL
    Posts
    26
    +1
    2
    Quick Fix for the sifb. On the Polaris MSX 110 and 150, remove the seat and look in the back end and find the sifb unit (it will be just hanging there) PT# ends with 507. Remove it form the multi pin conn. Find the Purple wire and the Blue/White wire in the conn. Run a jumper from purple to the blue/white wire. "That it, your done". Take it for a ride, it will work just fine. The only change is, Remember to remove the lanyard. If not it will run the battery down. The ski will shut down with the kill button or the lanyard removal.

  10. +1 by:


  11. #20
    hill160881's Avatar
    Join Date
    Jun 2014
    Location
    The delta Ca
    Posts
    2,048
    +1
    255
    I will give this a try To confirm it works on all units.

    But good info! Everyone has wondered if you could jump some wires and get it to function.

    More than an emergency this will make a great diagnostic tool to test for a bad system IFB module.

Page 2 of 4 FirstFirst 1234 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: 04-21-2015, 12:22 PM
  2. SIFB in MSX 110
    By nunoc in forum MSX/Matrix
    Replies: 4
    Last Post: 02-21-2014, 10:33 AM
  3. Looking for info on MSX 110
    By aprilia-ryan in forum MSX/Matrix
    Replies: 2
    Last Post: 09-06-2010, 08:45 PM
  4. Need help again on MSX 110
    By harleyboy in forum MSX/Matrix
    Replies: 0
    Last Post: 06-05-2010, 10:31 PM
  5. I just got a TRD box for my Msx 110 04
    By f150vtx in forum Polaris PWC Performance
    Replies: 6
    Last Post: 05-31-2007, 11:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •