Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: problem gauge

  1. #11

    Join Date
    Sep 2006
    Location
    San Juan, Puerto Rico, Puerto Rico
    Posts
    130
    Is there any way to fix it or any person who manages

  2. #12
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    41,807
    +1
    2,091
    Quote Originally Posted by freddypr1 View Post
    Is there any way to fix it or any person who manages
    I have never opened the casing of the NGI display since failures are rare.

    A good used replacement NGI display should not be hard to find or expensive, as this display is only used on the MSX 140 model, sold in 2003 and 2004.

    The MSX 110 and MSX 150 use a slightly different NGI display model without the oil level indicator.

  3. #13

    Join Date
    Sep 2006
    Location
    San Juan, Puerto Rico, Puerto Rico
    Posts
    130
    What it is advisable to find if i wore one for sale, but as I am sure is working well, I want to buy

  4. #14

    Join Date
    Sep 2006
    Location
    San Juan, Puerto Rico, Puerto Rico
    Posts
    130
    Are any of them here works for me

    http://www.trailtechproducts.co.uk/a...formation.html





    QUOTE=freddypr1;2366929]What it is advisable to find if i wore one for sale, but as I am sure is working well, I want to buy [/QUOTE]

  5. #15

    Join Date
    Sep 2006
    Location
    San Juan, Puerto Rico, Puerto Rico
    Posts
    130
    Msx gauge of 110 or 150 works well in msx 140

    QUOTE=K447;2366921]
    Quote Originally Posted by freddypr1 View Post
    Is there any way to fix it or any person who manages
    I have never opened the casing of the NGI display since failures are rare.

    A good used replacement NGI display should not be hard to find or expensive, as this display is only used on the MSX 140 model, sold in 2003 and 2004.

    The MSX 110 and MSX 150 use a slightly different NGI display model without the oil level indicator.[/QUOTE]

  6. #16
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    41,807
    +1
    2,091
    Quote Originally Posted by freddypr1 View Post
    Msx gauge of 110 or 150 works well in msx 140

    ...
    Is that a question or a statement?

  7. #17

    Join Date
    Sep 2006
    Location
    San Juan, Puerto Rico, Puerto Rico
    Posts
    130
    Is that a question ?


Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Gas gauge problem?
    By seadooingfreak in forum 4-Tec Performance
    Replies: 4
    Last Post: 04-21-2008, 06:04 AM
  2. Gauge problems
    By explude in forum Polaris How To & FAQs
    Replies: 60
    Last Post: 03-26-2008, 08:46 PM
  3. Gas gauge problem!
    By dcs191919 in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 09-05-2007, 07:45 AM
  4. Weird Gauge Problem
    By '02GPRider in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 04-09-2007, 11:38 AM
  5. New Depth Gauge Transducer/Program Installation Problem
    By STEAMBOAT in forum 4-Tec Performance
    Replies: 2
    Last Post: 11-01-2005, 12:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •