Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: Oil in bilge???

  1. #11
    DP.'s Avatar
    Join Date
    Aug 2007
    Location
    Cayman Islands
    Posts
    430
    +1
    6
    An O-ring on the oil pump or oil cooler could be broken. I've seen this happen before!


  2. #12
    Gus13letter's Avatar
    Join Date
    Apr 2008
    Location
    Tampa Bay, FL
    Posts
    8,405
    +1
    927
    Check your oil dipstick. They changed the design to a better setup. Mine was broken causing oil in the hull like you are describing. Check mine out here.

    http://www.greenhulk.net/forums/showthread.php?t=184494&page=20&p=2306033&viewfull =1#post2306033

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 300 Rxp oil in bilge
    By RK Performance in forum 4-Tec Performance
    Replies: 12
    Last Post: 08-23-2016, 02:32 PM
  2. Oil in the Bilge RXP-X 300 !
    By RXP-X 2011 in forum 4-Tec Performance
    Replies: 7
    Last Post: 02-07-2016, 03:03 PM
  3. Quick question on Oil in the bilge
    By xanthras in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-15-2009, 09:57 PM
  4. Newby needs help - oil and metal shavings in bilge of 97 WV760
    By 93AmSkier in forum Yamaha Old School Skis
    Replies: 12
    Last Post: 08-22-2008, 10:37 AM
  5. Newby needs help - oil and metal shavings in bilge of 97 WV760
    By 93AmSkier in forum Yamaha Open Discussion
    Replies: 0
    Last Post: 08-14-2008, 12:27 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •