Results 1 to 7 of 7
  1. #1

    Join Date
    Sep 2006
    Location
    Kanchanaburi Thailand for the next 2 years
    Posts
    372
    +1
    10

    Pro 785 runs better with seat off to rich ?

    Have a 785 that with seat on runs at high speed than slowly dies. Hit the primer with 3 to 4 shots. starts right up and runs great for 30 seconds again dies. With seat off runs fine . Check no exhaust leaks, fuel leaks, new fuel pumps , carbs rebuilt, and new fuel lines. Plug color good. and check pickup tube too rich fuel mixture ? Kind at a lost what to try next


  2. #2
    MSX 150 guy lives on Mr. GP1800's Avatar
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    17,884
    +1
    1,586
    Check for exhaust leaks

  3. #3
    Rasta Mon Condoms We Be Jammin!!!!! TxVirageTx's Avatar
    Join Date
    Aug 2006
    Posts
    6,012
    +1
    666
    yup exhaust leaks

  4. #4

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,769
    +1
    121
    did you pull the collector and check it for pin holes

  5. #5

    Join Date
    Sep 2006
    Location
    Kanchanaburi Thailand for the next 2 years
    Posts
    372
    +1
    10
    No, checked for exhaust leaks none, anyways bigger issues now
    Thanks for the input

  6. #6
    Bing-A-Ding-Ding-Ding, Brrrrrap! Brrrrrrrrrap!!! Polaris_Nut#1's Avatar
    Join Date
    Aug 2006
    Location
    Pittsfield, MA
    Posts
    3,351
    +1
    26
    Check the exhaust hoses for internal collapses. It could have a bubble on the inside that smells up somewhere blocking exit flow.

  7. #7

    Join Date
    Sep 2006
    Location
    Kanchanaburi Thailand for the next 2 years
    Posts
    372
    +1
    10
    Update , was the stator when cold readings were within spec, when hot readings went off the wall . Thinking with the seat off maybe was getting cooler air over the engine Big thanks to Lugs 785 for helping me out !!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Pro 785 running very strange... please help
    By jcjw1998 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 09-07-2010, 07:38 AM
  2. FS Pro 785 Triple Pipes With Jetworks Valve
    By seatsR4toilets in forum Polaris Classifieds
    Replies: 10
    Last Post: 03-14-2010, 09:23 AM
  3. Please help....97 pro 785 runs then dies
    By billybobtucson in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 07-30-2009, 12:48 AM
  4. Pro 785 rpm's and what oil to use
    By sloan_william@msn.com in forum Polaris Open Discussion
    Replies: 8
    Last Post: 09-25-2008, 09:39 AM
  5. 97 pro 785 runs good out of water but not in
    By bidwell785 in forum Polaris Open Discussion
    Replies: 21
    Last Post: 07-16-2007, 12:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •