Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 28
  1. #11
    Flower girl's Avatar
    Join Date
    Aug 2013
    Location
    London ont
    Posts
    28
    Tried the reverse plug didn't make a difference
    Any other ideas ??? ��


  2. #12
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    42,268
    +1
    2,138
    Quote Originally Posted by Flower girl View Post
    Tried the reverse plug didn't make a difference
    Any other ideas ??? ��
    Remind me, is the TPS new?

  3. #13
    Flower girl's Avatar
    Join Date
    Aug 2013
    Location
    London ont
    Posts
    28
    Yes tps is new 25 hours ago

  4. #14
    Flower girl's Avatar
    Join Date
    Aug 2013
    Location
    London ont
    Posts
    28
    Any other ideas air or water temp sensor thanks

  5. #15
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    42,268
    +1
    2,138
    Quote Originally Posted by K447 View Post
    ...
    Does the engine simply slow down and maintain a steady but slower speed, or does it surge and miss?
    ?

  6. #16
    Flower girl's Avatar
    Join Date
    Aug 2013
    Location
    London ont
    Posts
    28
    Engine slows down to almost idle or so while it sputters
    If I let of throttle for a second or so and accelerate rpm go back up to 6600
    and she runs fine for a minute than it starts again
    This is all random in morning good for 10-15 min full power
    And than it starts once or twice and than good for 5 min again and than
    it maybe happens twice in a row again
    I hope that helps

  7. #17
    Quote Originally Posted by Flower girl View Post
    Engine slows down to almost idle or so while it sputters
    If I let of throttle for a second or so and accelerate rpm go back up to 6600
    and she runs fine for a minute than it starts again
    This is all random in morning good for 10-15 min full power
    And than it starts once or twice and than good for 5 min again and than
    it maybe happens twice in a row again
    I hope that helps
    K447 helped me with your same issue , my ski was doing the exact same thing! Drops down to idle thinking its going to stop completly
    nurse the throotle away it goes again .
    Replace the TPS again and make sure the TPS plug is clean and secure.


    Good Luck

  8. #18
    Flower girl's Avatar
    Join Date
    Aug 2013
    Location
    London ont
    Posts
    28
    Will bring it to dealer on Monday and hook it up to the
    Computer and than we will see
    But I think it could the tps again maybe it is not working
    right
    Thanks so far will post update

  9. #19
    Flower girl's Avatar
    Join Date
    Aug 2013
    Location
    London ont
    Posts
    28
    Water temp Sensor shows a failed code will replace it and than
    We are good I hope

  10. #20
    ThrottleOut's Avatar
    Join Date
    Aug 2011
    Location
    Corning, NY
    Posts
    776
    +1
    33
    Let us know if that fixes the issue. Good to know for future reference.

Page 2 of 3 FirstFirst 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. My 2003 msx 140 runs good under power but dies at idle
    By Adco1110 in forum Polaris Open Discussion
    Replies: 8
    Last Post: 08-15-2016, 07:20 PM
  2. MSX 140 Runs Rough at low-mid RPM range
    By Makon in forum MSX/Matrix
    Replies: 4
    Last Post: 08-04-2014, 08:27 PM
  3. MSX 140 Runs Great...For1/2 hr to 40 min
    By RANDAL in forum Polaris Tech Tips and Info
    Replies: 4
    Last Post: 04-21-2014, 12:51 PM
  4. 03 MSX 140 Runs great then will only idle
    By 1100zxi in forum MSX/Matrix
    Replies: 4
    Last Post: 06-25-2012, 08:17 AM
  5. MSX 150 runs only at 7000 t/mn
    By NORWAX in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 09-27-2006, 11:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •