Page 5 of 6 FirstFirst ... 3456 LastLast
Results 41 to 50 of 53
  1. #41
    Rodsatheart's Avatar
    Join Date
    Nov 2014
    Location
    Arkansas SoCal transplant
    Posts
    549
    +1
    50
    Denatured alcohol. Makes sense, because I just fixed the instrument cluster on my truck a couple of weeks ago the same way.

  2. #42
    Opening up this thread again.
    I have 2 skis, 2003 STX-12f, and 2004 STX-12f.

    The 04 runs great, but the 03 needs a new display. I just picked 1 up on ebay for $400 which i thought was a good price, but next will be getting it installed. i have been browsing this thread and from what i can tell, it has the best info on what to do, step by step.

    My question: Do you have to remove the handlebars, or can the display be replaced with the handlebars in place? Thanks in advance for any advice, tips or overall guidance.

    Rb


  3. #43
    madtom's Avatar
    Join Date
    Apr 2018
    Location
    Virginia
    Posts
    74
    +1
    7
    Hi,
    And just to bump on this thread. I have a 2002 900STX and a 2003 12F STX. Both have flaky displays. Has anyone figured out a was to remove/simulate the display so that if we wanted to install analog gauges or build a new dash we wont have to do a standalone wiring harness? it's like they repackaged a motorcycle dash without taking into account the marine environment that must be endured.

    Tom

  4. #44
    hi, long time reader, first time poster here. been hunting for some info on an 08 ultra 1500 lx, non sc. looking to bench test the MFD, cant seem to find wiring diagram or which wires need jumped to test and see if it powers up. any help is appreciated, thanks!

  5. #45
    you got the male connector with four connections. Black wire goes to ground. Red wire goes to +12 volts. Red/White wire goes to 12 volts too. Hook up red and black, then the red/white wire to simulate power up in the boat.

    Everything should light up then go out.

  6. #46
    rojna's Avatar
    Join Date
    Jul 2019
    Location
    St Pete Florida
    Posts
    35
    +1
    1
    New to jet skis, just picked up a 2000 900 STX at auction, slowly going through it and reading a lot here for info, so far I have a bad display and a seized up jet pump. Motor spins and everthing else looks good ... neglected but good.

    So after reading this topic I have a question, will the stx run without the display ??

  7. #47
    Just picked up a used non running 08' STX-15. Looks to be in good shape, but the fuel pump and the display is bad. I have ordered a fuel pump, but the displays are really crazy expensive. I have the display out thanks to your help, but how does one really split open this display/meter case without damaging it? I realize this is an old thread, but someone must have been successful at it and the Ebay repair guys must have a technique that works. Any advise or direction would greatly be appreciated. Thanks and wish me luck with this thing. I am sure it will be fun.

  8. #48
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    7,833
    +1
    784
    It's not designed to come apart. You can remove the rubber plug on the back to try to dry it out, but that usually works only within a day or less of when it got water in it (or whatever happened).

    It is possible to cut it open using various means; Dremel tool, hot knife, etc. Corrosion start as soon as moisture gets in and power is applied. It eats up connections and conductive strips on the circuit board. I think the best thing to do is buy a decent one off of Ebay.

    Seal the back plug & wires with 3M 5200 Fast Cure.

  9. #49
    Dan-is-the-man's Avatar
    Join Date
    Jan 2019
    Location
    Central Fla
    Posts
    28
    +1
    2
    Quote Originally Posted by steve45 View Post
    It's not designed to come apart. You can remove the rubber plug on the back to try to dry it out, but that usually works only within a day or less of when it got water in it (or whatever happened).

    It is possible to cut it open using various means; Dremel tool, hot knife, etc. Corrosion start as soon as moisture gets in and power is applied. It eats up connections and conductive strips on the circuit board. I think the best thing to do is buy a decent one off of Ebay.

    Seal the back plug & wires with 3M 5200 Fast Cure.

    Steve, I'm going to seal mine for preventive maintenance. Do I just seal underneath the grommet ring, and where the wires exit the grommet?

  10. #50
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    7,833
    +1
    784
    That's what I did. Pull out the grommet and put sealer all around it, then all over the wires where they go into the plug. It looks messy, but keeps the water out.


Page 5 of 6 FirstFirst ... 3456 LastLast

Thread Information

Users Browsing this Thread

There are currently 3 users browsing this thread. (0 members and 3 guests)

Similar Threads

  1. 95 Polaris SL 750, MULTI FUNCTION DISPLAY . please help
    By 750slt in forum Polaris Open Discussion
    Replies: 8
    Last Post: 05-30-2009, 10:56 PM
  2. **Help Needed - Multi Function Display
    By bradcope in forum Yamaha Old School Skis
    Replies: 2
    Last Post: 01-16-2009, 11:08 AM
  3. WTB mfd multi function display 8 pin for polaris sl 1050
    By boatinj in forum Polaris Classifieds
    Replies: 26
    Last Post: 01-01-2009, 07:43 PM
  4. 95 vs 96 multi function display
    By 95yami701 in forum Yamaha Old School Skis
    Replies: 0
    Last Post: 07-21-2008, 06:44 PM
  5. 1996 SLT780 Multi-Function Display Woes
    By Juiceman99350 in forum Polaris How To & FAQs
    Replies: 12
    Last Post: 08-06-2007, 08:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •