Page 3 of 16 FirstFirst 1234513 ... LastLast
Results 21 to 30 of 154
  1. #21
    Eastside Powersports Slow 91's Avatar
    Join Date
    Sep 2008
    Location
    River Crew CT
    Posts
    4,329
    +1
    566
    How much time did you put on the motor before it went? also, at what RPM did it fail at?


  2. #22
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,453
    +1
    182
    How many RPM's when it vented?

  3. #23
    To much is never enough Badvgood's Avatar
    Join Date
    Jun 2012
    Posts
    699
    +1
    31
    Quote Originally Posted by Slow 91 View Post
    How much time did you put on the motor before it went? also, at what RPM did it fail at?
    4 Hours, say 2 testing / running up on the trailer / hose with no C clip. 1 On the ramp dialing in CMD and 1 on the water
    Last edited by Badvgood; 04-29-2013 at 10:08 AM. Reason: Spelling

  4. #24
    To much is never enough Badvgood's Avatar
    Join Date
    Jun 2012
    Posts
    699
    +1
    31
    2800 RPM - But I noticed a knock befor so shut down and was awaiting help. The ski was going to get beached in surf onto pebbles so restarted it to get 100 yards further out. Just off tickover it stopped as the rod let go, hence not to much damage to the block.
    Last edited by Badvgood; 04-29-2013 at 10:08 AM. Reason: Spelling

  5. #25
    Eastside Powersports Slow 91's Avatar
    Join Date
    Sep 2008
    Location
    River Crew CT
    Posts
    4,329
    +1
    566
    How was the motor before it let go? did it have any type of vibration?

  6. #26
    To much is never enough Badvgood's Avatar
    Join Date
    Jun 2012
    Posts
    699
    +1
    31
    Smooth as silk at idle and up to about 4k - After that it gets bit hard to tell but it certainly did not feel 'lumpy'

    We spoke about crank balancing some time ago. I got it balanced to 55%. The machine shop asked for pistons, rods, shells, rings, clips etc.

    Here in the UK it gets costly to ship stuff back and forth to the States for work.

    I was wondering if that may have been a contributing factor. What ya thinking Slow91?

  7. #27
    Eastside Powersports Slow 91's Avatar
    Join Date
    Sep 2008
    Location
    River Crew CT
    Posts
    4,329
    +1
    566
    im leaning towards a rod bolt failure, either not enough stretch or too much. As far as balancing of the crank, Im not sure if that would have caused it.

  8. #28
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,341
    +1
    261
    This sucks.

    What was your final torque to get proper stretch?

  9. #29
    To much is never enough Badvgood's Avatar
    Join Date
    Jun 2012
    Posts
    699
    +1
    31
    Quote Originally Posted by jp1300r View Post
    This sucks.

    What was your final torque to get proper stretch?
    As per the Molar instruction sheet. 25 ft lbs + 55 deg

    They state you can use either the stretch method or the torque and angle method. 100% it was done to 25 ft lbs and 55 deg - Not 26 ft lbs or 24 or 54 deg - Everything was spot on with recently calibrated digital gauges.

    I am thinking the torque angle method sucks right now and wish I had gone with stretch method.

    Still, wait what I find inside as there may be more to it yet....

  10. #30
    To much is never enough Badvgood's Avatar
    Join Date
    Jun 2012
    Posts
    699
    +1
    31
    Photo taken just before the cases were mated together. As you can see, it was a nice clean build with care being taken.....
    Click image for larger version. 

Name:	ImageUploadedByTapatalk1367253830.917413.jpg 
Views:	234 
Size:	62.7 KB 
ID:	299779
    Click image for larger version. 

Name:	ImageUploadedByTapatalk1367253868.618304.jpg 
Views:	236 
Size:	59.5 KB 
ID:	299780

Page 3 of 16 FirstFirst 1234513 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS - Parts New/Used ARP rod bolt set
    By Slow 91 in forum Sea Doo Classifieds
    Replies: 2
    Last Post: 09-15-2016, 09:25 PM
  2. Carrillo Rod Bolt Stretch
    By Glade Rider in forum 4-Tec Performance
    Replies: 4
    Last Post: 03-12-2014, 05:22 PM
  3. Carrillo Rod Bolt/ARP Stud Bolt Torque
    By dnielsen in forum 4-Tec Performance
    Replies: 1
    Last Post: 04-29-2013, 04:39 PM
  4. 4-tec ARP Rod bolts - Anyone able to use them?
    By boostaholic in forum 4-Tec Performance
    Replies: 9
    Last Post: 03-09-2010, 01:25 AM
  5. ARP Bolts: Rod Bolts/Rocker Bolts Torque specs? Help!
    By boostaholic in forum 4-Tec Performance
    Replies: 4
    Last Post: 04-12-2009, 06:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •