Page 2 of 9 FirstFirst 1234 ... LastLast
Results 11 to 20 of 87
  1. #11
    ultraman250's Avatar
    Join Date
    Mar 2007
    Location
    Philippines
    Posts
    236
    +1
    1
    Quote Originally Posted by smokeysevin View Post
    I think it 3,25 I ordered a high temp silicone replacement (hts brand)

    Sean
    Thanks! Will look into that. Looks like I will also need those two piston ring like things. Only half rings were left and it is brittle and badly corroded. I can find the coupler locally but the rings will have to be ordered from there. There goes two weekends of riding.


  2. #12
    My name is Sean and I am addicted to STXs smokeysevin's Avatar
    Join Date
    May 2008
    Location
    Houston
    Posts
    4,764
    +1
    356
    Yeah I have been there, I tried to find a local replacement too.

    Sean

  3. #13
    ultraman250's Avatar
    Join Date
    Mar 2007
    Location
    Philippines
    Posts
    236
    +1
    1
    So I found the coupler locally but I ordered the metal gasket from the US and will get here on June 5. Do you think there will be a problem if I use it for one ride without it? Do you have any suggestions as to what I can replace it with for the meantime? Riding season is ending here soon and I wanna get one last ride in before the water becomes choppy. Thanks in advance.

  4. #14
    My name is Sean and I am addicted to STXs smokeysevin's Avatar
    Join Date
    May 2008
    Location
    Houston
    Posts
    4,764
    +1
    356
    You will burn up the coupler again.

    Wait on the rings.

    Sean

  5. #15
    ultraman250's Avatar
    Join Date
    Mar 2007
    Location
    Philippines
    Posts
    236
    +1
    1
    Okay will do that. Thanks, Sean.

  6. #16
    If you don't find anything in there but are still having issues go through each of the hoses and check for blockages. On the early model 12f and 15f there was another cooling manifold underneath the intake manifold on the right side of the motor that was prone to corrosion and led to 2 problems, overheating due to blockages or large amounts of water filling the hull. There is a newer part that replaces the old one on the 12f and 15f and has a much more corrosion resistant brass fitting.

    "The other part that commonly causes problems is the output shaft cover on the back of the engine. While this part does not cause problems under normal circumstances, if left in salt water or poorly flushed it will corrode, plug, or leak.

    If the ski had not been flushed properly or run in shallow sandy water there is a good chance that the brass fittings have some debris in them restricting water flow, if you have checked the hoses and pump but still have overheating problems this is a good thing to check. "

    Do you have any more specifics on "the older models" that you are referring to? What years? And/or what part numbers are you referring to? Thanks for this thread, it really has a ton of great information

  7. #17
    My name is Sean and I am addicted to STXs smokeysevin's Avatar
    Join Date
    May 2008
    Location
    Houston
    Posts
    4,764
    +1
    356
    Quote Originally Posted by deeringschef1971 View Post
    Do you have any more specifics on "the older models" that you are referring to? What years? And/or what part numbers are you referring to? Thanks for this thread, it really has a ton of great information
    I think it was 03-08 but I am not sure. There are a few different part numbers throughout the years, the one you want is from a 2011 15f, on bike bandit the part number is 1409674.

    Sean

  8. #18
    This is a great post with a ton of good information on the 12F. Any chance you have looked at my post "05 STX 12F no fuel or spark to #1 & #4"? I could really use some help. I am banging my head against the wall with this issue.
    Thanks!

  9. #19
    My name is Sean and I am addicted to STXs smokeysevin's Avatar
    Join Date
    May 2008
    Location
    Houston
    Posts
    4,764
    +1
    356
    Quote Originally Posted by Chris Sadler View Post
    This is a great post with a ton of good information on the 12F. Any chance you have looked at my post "05 STX 12F no fuel or spark to #1 & #4"? I could really use some help. I am banging my head against the wall with this issue.
    Thanks!

    I got a post to you yesterday, when we get you sorted out I will update the thread here to reflect the problem.

    Sean

  10. #20
    Quote Originally Posted by smokeysevin View Post
    Quote Originally Posted by deeringschef1971 View Post
    Do you have any more specifics on "the older models" that you are referring to? What years? And/or what part numbers are you referring to? Thanks for this thread, it really has a ton of great information
    I think it was 03-08 but I am not sure. There are a few different part numbers throughout the years, the one you want is from a 2011 15f, on bike bandit the part number is 1409674.

    Sean
    I have a 2011 stx-15f and in dealer mode the fault code is saying dos service code 31 witch is vehicle down sensor do you have any advice on how to fix this problem or do i just take it to a dealer

Page 2 of 9 FirstFirst 1234 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 141
    Last Post: 09-17-2017, 11:23 AM
  2. WTB Looking for a good or bad STX-12F or STX-15F gauge for cheap
    By soakin in forum Kawasaki Open Discussion
    Replies: 9
    Last Post: 10-31-2015, 07:21 AM
  3. WTB - Parts WTB STX-12f or STX-15f display gauge WTB
    By leejax01 in forum Kawasaki Classifieds
    Replies: 2
    Last Post: 10-14-2015, 08:54 AM
  4. Kawasaki STX-12f 2004 Speedometer Sometimes Works, Sometimes Does Not
    By msabtello in forum Kawasaki How To & FAQs
    Replies: 1
    Last Post: 09-07-2011, 09:55 AM
  5. WTB Carbs for my STX-R or Ultra 150
    By joewharton2 in forum Kawasaki Classifieds
    Replies: 6
    Last Post: 09-04-2009, 04:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •