Search

Type: Posts; User: Ausjet01

Search: Search took 0.00 seconds.

  1. Replies
    12
    Views
    933

    I was going off the workshop manual. It says 83ml...

    I was going off the workshop manual. It says 83ml at a minimum. That gave me a bump steer thinking it was good. Thanks mate I’ll order a new pump assembly
  2. Replies
    12
    Views
    933

    So I took the ski out today with a fuel pressure...

    So I took the ski out today with a fuel pressure gauge on the supply line to the rail. For the first 5 mins fuel pressure held 42psi at WOT then it started to drop and fluctuate from 25-30psi. Looks...
  3. Replies
    12
    Views
    933

    Quick update, checked the intercooler, was clean,...

    Quick update, checked the intercooler, was clean, fitted a new fuel vent valve, SCOM wiring looked fine, checked fuel flow on 3 second prime was on spec at ~90ml. Took it out this arvo- still...
  4. Replies
    12
    Views
    933

    Thanks for the info mate, I have recently rebuilt...

    Thanks for the info mate, I have recently rebuilt the tensioner and fitted a grease nipple to it. Ive also had the whole exhaust apart and machined the surfaces flat, cleaned the water passages out...
  5. Replies
    12
    Views
    933

    No fault codes on the dash. I had the jet pump...

    No fault codes on the dash. I had the jet pump rebuilt last week also and whilst he was there he put the candoo tool on it. No active or logged codes whilst running on the hose. I do have a SCOM,...
  6. Replies
    12
    Views
    933

    View Post

    Hey folks, first time poster, long time lurker. I have a 2013 ultra 300x which has surging/revving problem which I havnt been able to fix for some time now.
    When I launch the ski, it will perform...
Results 1 to 6 of 6