Search

Type: Posts; User: PopovirageI

Page 1 of 2 1 2

Search: Search took 0.00 seconds.

  1. Replies
    104
    Views
    7,032

    Installed the tps sensor still runs the same,...

    Installed the tps sensor still runs the same, when I press the valve on the fuel line fuel comes out pretty hard. Need to find a fuel pressure gauge I guess.
  2. Replies
    104
    Views
    7,032

    Tps sensor will be here Tuesday. I haven't been...

    Tps sensor will be here Tuesday. I haven't been able to locate a gauge to check fuel
    preasure. Also I have the correct plugs in it now.
  3. Replies
    104
    Views
    7,032

    Both has 5 amp fuses that are good

    Both has 5 amp fuses that are good
  4. Replies
    104
    Views
    7,032

    If it is these I've replaced both? ...

    If it is these I've replaced both?

    http://www.greenhulk.net/forums/attachment.php?attachmentid=413880&stc=1
  5. Replies
    104
    Views
    7,032

    I cannot seem to locate this fuse for the...

    I cannot seem to locate this fuse for the display, they say it's a 1/4 amp glass fuse but I haven't been able to find it, help with that would be appreciated.
  6. Replies
    104
    Views
    7,032

    I ordered a tps sensor the guy that rebuilt my...

    I ordered a tps sensor the guy that rebuilt my emm said it sounds like the tps sensor. Also when I bought the jet ski my display worked and now it does not any help with that would be appreciated?...
  7. Replies
    104
    Views
    7,032

    I put the new plugs In it and still does the same...

    I put the new plugs In it and still does the same thing.
  8. Replies
    104
    Views
    7,032

    Put the right plugs in and it does the same...

    Put the right plugs in and it does the same thing, when I unplug tps sensor it just doesnt idle as long. So when I first got it I drained all bad gas. Well someone from a marine store recommended...
  9. Replies
    104
    Views
    7,032

    I just had the emm rebuilt. Unplugging the tps...

    I just had the emm rebuilt. Unplugging the tps sensor changes nothing. I need to check fuel pressure, I verified regulator is good in pump. I checked the compression with one spark plug in and no...
  10. Replies
    104
    Views
    7,032

    Anybody?, would like to get this thing going by...

    Anybody?, would like to get this thing going by the end of the summer?
  11. Replies
    104
    Views
    7,032

    I checked the red and white wire further back....

    I checked the red and white wire further back. When it first cranks the volts jump up to 42 and then levels out and fluctuates between 37 and 38 volts, on both wires. I put the red probe to the red...
  12. Replies
    104
    Views
    7,032

    Anybody?

    Anybody?
  13. Replies
    104
    Views
    7,032

    https://youtu.be/yWeTmwO4w6Y ...

    https://youtu.be/yWeTmwO4w6Y

    https://youtu.be/_SwvDeLVtK4

    first video is the rear injector second one is the front injector
  14. Replies
    104
    Views
    7,032

    The engine spudders and runs so bad I don't see...

    The engine spudders and runs so bad I don't see how I could get a good enough reading. I need to check fuel pressure.
  15. Replies
    104
    Views
    7,032

    No injectors were unplugged. I checked each red...

    No injectors were unplugged. I checked each red and white wire on both injectors. I unplugged the spark plug wires to get the cranking volts. Also I checked my compression with one spark plug in and...
  16. Replies
    104
    Views
    7,032

    Here are my readings . Rear injector running is...

    Here are my readings . Rear injector running is 28 volts and front injector running is 37.5 volts. Here are my readings with the plug wires unplugged. Rear injector reads 22.8 and front injector...
  17. Replies
    104
    Views
    7,032

    Got it where does the volt meter need to be set?...

    Got it where does the volt meter need to be set? And are those good numbers for a good engine?
  18. Replies
    104
    Views
    7,032

    I checked the compression on rear cylinder it was...

    I checked the compression on rear cylinder it was 165 and front cylinder was 160. Not very good with a volt meter. In the picture is what I set it on to check the injectors. And do I put the negative...
  19. Replies
    104
    Views
    7,032

    Check one cylinder with other plug in right? What...

    Check one cylinder with other plug in right? What number should I be getting? To me it sounds as if maybe the injector is sticking?
  20. Replies
    104
    Views
    7,032

    https://youtu.be/4SvdV3DCEs4 never checked...

    https://youtu.be/4SvdV3DCEs4

    never checked compression yet either, does she sound normal?
  21. Replies
    104
    Views
    7,032

    Installed pump and still it cranks runs and when...

    Installed pump and still it cranks runs and when you give it throttle it sputters and dies.
  22. Replies
    104
    Views
    7,032

    So the center vent or the end connects to the...

    So the center vent or the end connects to the battery?
  23. Replies
    104
    Views
    7,032

    http://www.greenhulk.net/forums/attachment.php?att...

    http://www.greenhulk.net/forums/attachment.php?attachmentid=412652&stc=1
    So this connects to the top of the pump to let it breathe I'm guessing? Is this all that it connects to or is the other end...
  24. Replies
    104
    Views
    7,032

    I went ahead and put the used pump back in it off...

    I went ahead and put the used pump back in it off the used one I bought on eBay. It was an aftermarket pump specifically for the virage that come with new filters so I used the filters and went back...
  25. Replies
    104
    Views
    7,032

    Got pump assembly torn apart to replace the pump...

    Got pump assembly torn apart to replace the pump and the negative wire leed fell
    out of the fuel pump that the wire attaches to. So I'm real sceptical on getting a replacement pump from the company...
Results 1 to 25 of 48
Page 1 of 2 1 2