Search

Type: Posts; User: MA-Chris

Page 1 of 2 1 2

Search: Search took 0.00 seconds.

  1. Replies
    27
    Views
    2,030

    That is where we are right now, I want to have...

    That is where we are right now, I want to have 2-3 that all run at the same time. We keep our boat, and these skis at a friends house in town. It seems I should focus on the 96 and newer skis right...
  2. Replies
    27
    Views
    2,030

    "Best" Polaris Jetskis

    So my 1996 SL700 is more or running so I am looking for a second ski.

    The SL700 has enough performance for us and like the simplicity of the ski.

    Are there any models/years I should look out...
  3. Replies
    3
    Views
    254

    I was just letting everyone know I am not missing...

    I was just letting everyone know I am not missing any spacers that would cause the bearings to bind. There is one aluminum spacer in-between the bearings and a steel spacer that the oil seals ride...
  4. Replies
    3
    Views
    254

    Polaris SL700 Impeller preload

    I just rebuilt my SL700 impeller with 2 new oil seals and two new Timken sealed bearings.

    I torqued the impeller down to 100 ft/lb and the impeller is a little tighter than expected. It turns...
  5. Which ways do the seals face? When I took my...

    Which ways do the seals face? When I took my 1996 coupler with grease fitting apart, both seals were installed flat side in. That doesn't feel right to me, I would think both flat slides of the...
  6. Absolutely, I am just trying to join the chorus...

    Absolutely, I am just trying to join the chorus of CHECK YOUR BATTERY since even with a fast crank, the CDI may not be firing. All my other engine experience, mainly outboards, will start on a low...
  7. SL700 intermittent hot start, battery not charging

    Alright, I think I finally figured out my hot start issue, the battery is/was not charging. Since I was unsure of the working condition of the ski, I bought the following cheap battery:
    ...
  8. In a 1996 sl700 there is a LR-21 and a LR-52. ...

    In a 1996 sl700 there is a LR-21 and a LR-52. Which one is the regulator that "charges" the battery? I am guessing it is the LR-21?

    Thanks,
    Chris
  9. Replies
    38
    Views
    2,146

    Alright, I may have figured out my hot start...

    Alright, I may have figured out my hot start issue, the silly battery is not charging! I put a jumpstarter on it tonight and it fired right up.

    What works?
    Motor starts.
    Trim motor works when...
  10. Replies
    38
    Views
    2,146

    Forgot to add, I was also able to take the trim...

    Forgot to add, I was also able to take the trim motor apart, with the help of Kano Kroil since it was corroded together and get that running again.

    I sprayed CRC 6-56 in the motor and it loosened...
  11. Replies
    38
    Views
    2,146

    So we had much success last night. What did I...

    So we had much success last night. What did I do?
    1. drained and refilled the gas tank with fresh gas.
    2. drained and refilled the oil tank
    3. changed the fuel filters
    4. replaced the trim motor...
  12. Replies
    38
    Views
    2,146

    I received my new trim motor today, the seller...

    I received my new trim motor today, the seller failed to mention that the indicator cable was corroded shut. No problem, I just swapped the motor and gearbox into my jetski. I hooked a battery up...
  13. Replies
    38
    Views
    2,146

    Thanks, the new trim motor shows up tomorrow so I...

    Thanks, the new trim motor shows up tomorrow so I will start troubleshooting with that installed.

    Looking at the schematic above, I have no idea why the trim motor being connected should have an...
  14. Replies
    38
    Views
    2,146

    On the positive note I got a new fuel sender...

    On the positive note I got a new fuel sender float and now my gas gauge works properly.

    I did the tests above and I did not observe more than 1v when the trim switch was in the off position.
    ...
  15. Replies
    38
    Views
    2,146

    Yes, the float is the issue. I took the sender...

    Yes, the float is the issue. I took the sender out of the tank and when I flip the sender over, the gauge reads just fine. One more problem solved.

    I wish I could figure out the relation...
  16. Replies
    38
    Views
    2,146

    I ran a few tests: All the wiring looks good,...

    I ran a few tests:

    All the wiring looks good, the wires are all connected to the right spots on the circuit board.
    I disconnected the trim motor.
    While running I have 2.5v on the red/white wire...
  17. Replies
    38
    Views
    2,146

    Ok, that gives me a bunch of things to check. ...

    Ok, that gives me a bunch of things to check.

    I am going to do the following:
    Verify all the wiring.
    Disconnect the trim motor.
    Disconnect the fuel sender and check the resistance to make...
  18. Replies
    38
    Views
    2,146

    Ugh, ok. Where is the voltage regulator...

    Ugh, ok. Where is the voltage regulator physically located? I wonder if it burned out with the dead short in the trim motor? That could also explain the dead fuel gauge.

    I hate that I can't run...
  19. Replies
    38
    Views
    2,146

    Ok, I will get that water out tomorrow. Thanks...

    Ok, I will get that water out tomorrow. Thanks for all your help to this point!
  20. Replies
    38
    Views
    2,146

    I hear you, I just haven't run into anything that...

    I hear you, I just haven't run into anything that has shown me the carbs need to be rebuilt. The engine starts right up, accelerates well and has excellent top end. There is no hesitation or hard...
  21. Replies
    38
    Views
    2,146

    I think I solved my rough acceleration issue. ...

    I think I solved my rough acceleration issue. Before investing too much much into this ski, I want to have it run fairly well. I did not want to rebuild the carbs just yet.

    I noticed that the...
  22. Replies
    38
    Views
    2,146

    I forgot to ask, what fuel lines and filters are...

    I forgot to ask, what fuel lines and filters are everyone using? I don't seem to have an oil filter right now.

    Is standard reinforced 1/4" line appropriate?
  23. Replies
    38
    Views
    2,146

    Well, good news/bad news. Disconnecting the...

    Well, good news/bad news.

    Disconnecting the trim motor seemed to fix my warm start issue. As I stated earlier, the trim motor was a dead short so it must have been powering the circuity when...
  24. Replies
    38
    Views
    2,146

    Hi casey67...

    Hi casey67

    While trying to troubleshoot the trim motor, I noticed that the trim motor had a dead short. I may take it for a ride today and I certainly will disconnect the trim motor to eliminate...
  25. Replies
    38
    Views
    2,146

    Good to know about the exhaust pressure, I am...

    Good to know about the exhaust pressure, I am trying to eliminate issues.

    Thanks for your advice. It seems like I have two next steps:
    1 See if I have spark during the period it won't start
    2...
Results 1 to 25 of 27
Page 1 of 2 1 2