Search

Type: Posts; User: jpt7779

Page 1 of 8 1 2 3 4

Search: Search took 0.05 seconds.

  1. Replies
    15
    Views
    415

    My setup and what I suggest is to install the...

    My setup and what I suggest is to install the valve prior to the T connection, again this shuts off 100% water into the ski.

    You do not need to worry about restricting flow with these 3/4 hoses,...
  2. Replies
    15
    Views
    415

    Your #1 option is not correct. Just go get a...

    Your #1 option is not correct.

    Just go get a 3/4” hose from Home Depot or Lowes, with the Schedule 80 connections and a brass 3/4” shut off valve. Zip tie it to an easy access location. Come right...
  3. Well I use Amsoil, BUT not on my seafood!

    Well I use Amsoil, BUT not on my seafood!
  4. Replies
    32
    Views
    3,027

    the parts diagram you keep asking for is clearly...

    the parts diagram you keep asking for is clearly annotated in a Shop Manual, https://brpmanuals.com/.
  5. Replies
    15
    Views
    447

    Appears to be, BUT no way in hell I would put...

    Appears to be, BUT no way in hell I would put that used stator in my ski. As 1tommygunner1927 said, install a brand new OEM part as you don’t want to have to do this again!
  6. Replies
    15
    Views
    447

    Clearly the previous owner had issues with this,...

    Clearly the previous owner had issues with this, if it was mine I would install a 300 ski stator which has higher power amperage and solid wires straight to the VR.
  7. Since you have verified the ECM and sensors are...

    Since you have verified the ECM and sensors are not the issue, it is time to pull the engine AGAIN and remove the PTO housing, oil pumps, springs, etc and find out what is going on.
  8. Replies
    15
    Views
    447

    It depends! Connection may be fine and you...

    It depends!

    Connection may be fine and you have another issue.
    Connection may be fried, if so you can replace male / female ends with proper tools. Or cut the wires and splice.

    The stator...
  9. Replies
    3
    Views
    378

    When you post fuel regulator is it a RRFPR?...

    When you post fuel regulator is it a RRFPR? Running 58 psi static or reference line connected?
  10. Replies
    15
    Views
    447

    There are 3 yellow wires coming from the back of...

    There are 3 yellow wires coming from the back of the PTO housing from the stator. This is what generates power to the VR. There is a connection half way on the right side you need to check for...
  11. Did you install an OEM PTO bearing seal? OEM...

    Did you install an OEM PTO bearing seal? OEM parts use 2 Oetiker clamps not worm screw type gear clamps. The proper sized Oetiker clamping force will not allow the PTO seal to rotate at all. There...
  12. Replies
    13
    Views
    2,102

    There are a lot of us on this forum that have...

    There are a lot of us on this forum that have taken the impeller nose cone off, and have been running for many years without one.

    You will gain 0.69 mph running without it!
  13. Replies
    7
    Views
    325

    https://brpmanuals.com/seadoo-manual.htm

    https://brpmanuals.com/seadoo-manual.htm
  14. Replies
    13
    Views
    1,390

    Glad you found it, but also check/clean IAT...

    Glad you found it, but also check/clean IAT sensor and Throttle Body function as a leaking IC can/has trashed those parts also.

    Too many guys ask for help and never report back, so well done.
  15. http://greenhulk.net/forums/showthread.php?t=29403...

    http://greenhulk.net/forums/showthread.php?t=294030
  16. Need Advice: Dealer says ECU bad? Oil light & limp mode. Lots eliminated.

    476869476870476871
    The are two oil sensors, OPS and OSPS. If they have replaced and verified both sensors good and check the harness, then it is most likely the ECM.
  17. You guys really need to provide year and model...

    You guys really need to provide year and model info to help diagnose problems.

    The 2009 and older skis have Siemens ECUs and MPEMs that indicate different problems. The newer Bosch ECUs are more...
  18. Replies
    1
    Views
    252

    Clearly, 1-2 of the 3 motor mounts are broken....

    Clearly, 1-2 of the 3 motor mounts are broken. Common failure for skis that are used for jumping waves. Realignment will be a must, once you replace the motor mounts.

    I had this happen after...
  19. Replies
    4
    Views
    657

    http://greenhulk.net/forums/showthread.php?t=27260...

    http://greenhulk.net/forums/showthread.php?t=272608

    see post #22 for another fuel pump wiring solution with heavy gauge wiring. You could build it yourself for about $30, with the correct wiring...
  20. Replies
    4
    Views
    657

    https://www.4-tecperformance.com/index.php?main_pa...

    https://www.4-tecperformance.com/index.php?main_page=product_info&cPath=345_375_412&products_id=5470

    Ive been using the Aeromotive fuel pump / relay kit for years on my turbo ski with no issues....
  21. Replies
    33
    Views
    4,450

    https://www.defender.com/product3.jsp?name=scandvi...

    https://www.defender.com/product3.jsp?name=scandvik-aba-316-hose-clamp-cruiser-pack&path=-1|2243574|2243584&id=1871613

    Not AWAB but just as good in quality.
    ...
  22. Replies
    33
    Views
    4,450

    I have replaced several oetiker clamps over the...

    I have replaced several oetiker clamps over the years like oil cooler, fuel lines, PTO bearing seal, etc, but I did put my oetiker pliers on every clamp I could find. Unfortunately, OEM quality...
  23. Replies
    33
    Views
    4,450

    I have never had an Oetiker clamp fail on...

    I have never had an Oetiker clamp fail on anything. I replaced all my OEM clamps with AWAB SS and have not had any loose clamp issues since. I tried the T-clamps also, but prefer the AWABs.
  24. Replies
    2
    Views
    201

    There are 3 yellow wires coming from the rear PTO...

    There are 3 yellow wires coming from the rear PTO housing from the stator, with a connection 1/2 way to the VR. Check that connection for corrosion and continuity to the VR. It is a common failure...
  25. IMO, this is due to heat soak. Do you have a cold...

    IMO, this is due to heat soak. Do you have a cold air intake or is it buried inside the hull.

    Year and model info would help.
Results 1 to 25 of 200
Page 1 of 8 1 2 3 4