Search

Type: Posts; User: les4

Search: Search took 0.00 seconds.

  1. Replies
    19
    Views
    545

    Thank you for taking your time and watching the...

    Thank you for taking your time and watching the video, I am assembling now the jet pump and trying to find a leak. Will report back when complete.
  2. Replies
    19
    Views
    545

    Thanks for taking the time and watching the...

    Thanks for taking the time and watching the video.
    I have assembled the jet pump with a new wear ring, ones the ring is seated all the way impeller is spinning without binding, will test and record...
  3. Replies
    19
    Views
    545

    That sounds terrible man, hope u can fix it fast...

    That sounds terrible man, hope u can fix it fast and get it back on the water.
    Can you hear my engine running on one of the videos>? Comparing it to yours is it too loud? Like something is loose on...
  4. Replies
    19
    Views
    545

    Thank you all for spending time on this. I have...

    Thank you all for spending time on this.
    I have removed the pump and hooked up a water hose, a bit leaky due to missing o ring on the connector, found one later and fixed it, runs and starts fine,...
  5. Replies
    19
    Views
    545

    --------------------------------------------------...

    ------------------------------------------------------------------------------------------------------------------------------
    Oh man, why do I have backpressure, or it may feel like backpressure,...
  6. Replies
    19
    Views
    545

    It does? I have not noticed. It is on the...

    It does? I have not noticed. It is on the trailer.
    I will come home tonight and see if it is in fact running on two, I don't think so.

    It could be very labored, I guess. I have tried turning...
  7. Replies
    19
    Views
    545

    The ski looks like a freshwater, very clean. ...

    The ski looks like a freshwater, very clean.
    What I really meant is the impeller will eventually shave the binding part off not the bearing will readjust itself.
    When I took the jet pump off it...
  8. Replies
    19
    Views
    545

    Polaris Virage TX locks up now and then

    Hello everyone, hope yall doing well.
    I just want to say I looked everywhere to find help to solve my problem and so far no luck.

    I have recently purchased Polaris Virage Tx 2002 fuel injected....
  9. Don't really know what happened, it runs fine...

    Don't really know what happened, it runs fine now, for now I will assume it was improper mixture.
    Thank you all !
  10. I will check again, I did replaced them. Is there...

    I will check again, I did replaced them. Is there a way to just test probe them with a multimeter?
  11. Thanks, plug wire are new and as far as coil...

    Thanks, plug wire are new and as far as coil wires connected i think they are connected in the correct order, other wise it would run poor all the time and not sometime. What do u guys think about...
  12. Polaris Virage TX 2000 sometimes missfires at full throtle

    Hello everyone. Hello K447:) thanks for all your help in the past.
    I took my Polaris to the lake and it ran very nice for a while, after 20 min or so it started to what it seems to is misfire,...
  13. Thank you !I will monitor its (pump) operation...

    Thank you !I will monitor its (pump) operation for now. Do you by any chance know if i need to clamp any hoses when towing my polaris virage tx 2000 or seadoo gs 1998 (720cc)? I read on your webpage...
  14. Voltage is present at Orange when the engine is...

    Voltage is present at Orange when the engine is running, but has nothing on it when cranking.

    Bilge pump connected and I assume its running, since voltage is present, I just cant hear it. Will...
  15. Hello! Hope u can help. I have just now finished...

    Hello! Hope u can help.
    I have just now finished installing new LR module, starts fine, charges system now very well, the orange wire has power to it only when engine is running, when cranking its...
  16. Hello! Thanks for help again:) It does starts...

    Hello! Thanks for help again:)
    It does starts easy, but runs really rough. I was playing with it a bit before the rain started again:) here in Florida it rains almost everyday. It shakes really bad...
  17. Thank you. Rained outside all afternoon. I have...

    Thank you. Rained outside all afternoon. I have disconnected LR-module completely. Taped the ends. Black/white wire (not the one from module) grounded and tried to start the engine. No luck at this...
  18. Hello. Thank you for you time. I did...

    Hello. Thank you for you time.
    I did disconnected LR Module by leaving black and white wire on the ground terminal. Ski is completely dead and wont respond to start button at all. I am not sure...
  19. Cant seems to find good direction on how to...

    Cant seems to find good direction on how to bypass the LR module. Do you by any chance have any info on it?
  20. Will read on how to bypass LR and perform it now,...

    Will read on how to bypass LR and perform it now, The mfi seems to be working ok, it was replaced with a used one as when I got the ski it was fried. Along with a fuse, bilge pump and fuse for bilge...
  21. Thank you for the fast response k447. I have...

    Thank you for the fast response k447.
    I have checked ground to Lr and it checks out fine less then 1 ohm.
    The voltage at the battery shows 13.4 and droops to 11 to 10.6,10.8, ski starts fine but...
  22. No Spark after PWC-00-05 done on Polaris Virage Tx 2000. Please help:)

    Hello everyone! Would like to thank you all for letting me be a parts of this forum, have gotten so much info here in the past. Before I decided to create a new threat I can assure you I spend...
Results 1 to 22 of 22