Search

Type: Posts; User: stgnsw

Search: Search took 0.00 seconds.

  1. Replies
    4
    Views
    635

    The end float seems ok. It doesn't seem to...

    The end float seems ok.
    It doesn't seem to excessive.
    I tried measuring the difference by putting feeler gauges In there,its about
    .127mm
  2. Replies
    4
    Views
    635

    Hi sirbreaksalot Thanks for your reply, I will...

    Hi sirbreaksalot

    Thanks for your reply, I will check the crankshaft end play.

    What I have noticed is that it actually goes faster at 3/4 throttle.

    At full throttle it would rev to 7400rpms...
  3. Replies
    16
    Views
    1,049

    I am currently fixing my friends 2013 300x The...

    I am currently fixing my friends 2013 300x
    The exhaust valve snapped, the head clean came off the valve stem.
    It has 90 hours use.
  4. Replies
    4
    Views
    635

    -

    -
  5. Replies
    4
    Views
    635

    300x Impeller/Pump ?

    HI all
    Newb hear so sorry in advance if I posted in the wrong section.
    My 2013 300x jet pump bearings collapsed and the impeller locked/jammed up against the pump housing wear ring and the ski...
  6. Replies
    42
    Views
    3,310

    I have a 2013 ultra 300x which I've had for 3...

    I have a 2013 ultra 300x which I've had for 3 years.
    I have been looking at buying a GP1800 as I was looking to update.
    After inspecting a couple of them I have changed my mind.
  7. I have a Ultra 300 I've had for 3 years and was...

    I have a Ultra 300 I've had for 3 years and was looking at updating to a GP1800.
    After inspecting a couple of them I have changed my mind.
    The wear under the Hull on some of them I thought was...
  8. Replies
    63
    Views
    25,328

    Sticky: This happened to a friend. Unfortunately with a...

    This happened to a friend.
    Unfortunately with a bad outcome.
  9. Replies
    8
    Views
    2,533

    My ultra 300x trim stopped working. I tested the...

    My ultra 300x trim stopped working.
    I tested the switch and checked if it had power to the switch.
    I opened the trim box and tested the motor with a seperate power source and it worked.( the motor...
Results 1 to 9 of 9