Search

Type: Posts; User: lrugland

Search: Search took 0.00 seconds.

  1. Replies
    38
    Views
    4,512

    2004 Polaris Genesis is RUNNING. Had two pairs...

    2004 Polaris Genesis is RUNNING.

    Had two pairs flipped on the new aftermarket stator. Corrected those this morning and it started. Shut it down and it started again. Took it for a ride and all...
  2. Replies
    38
    Views
    4,512

    OK, here is how both my stators and 2 others...

    OK, here is how both my stators and 2 others tested out.

    1-12 1.0 ohm
    2-11 1.0 ohm
    3-10 .8 ohm
    4-9 .8 ohm
    5-8 .8 ohm

    This is different than other info out there.
  3. Replies
    38
    Views
    4,512

    Thanks for the info. I checked mine quick and I...

    Thanks for the info. I checked mine quick and I do have a few wires that do not match that layout. I will be changing them tomorrow to see if I can correct this.

    PLUS, my stator and old stator...
  4. Replies
    38
    Views
    4,512

    Well, took engine out of the craft and replaced...

    Well, took engine out of the craft and replaced the stator. Still will not pull over 10 volts to the injectors and will not start. Got it to start once and it ran great. Shut it down and then back...
  5. Replies
    38
    Views
    4,512

    Is there any chance that the TPS could control...

    Is there any chance that the TPS could control the voltage to the injectors?

    Just trying to lock down any other options it could be.
  6. Replies
    38
    Views
    4,512

    Thanks, EMM is good so it must be stator coil...

    Thanks, EMM is good so it must be stator coil output. Time to dig into that.
  7. Replies
    38
    Views
    4,512

    Think I found the issue. The voltage to...

    Think I found the issue. The voltage to injectors fluctuates. Sometime I get only 10v on crank and other times I get over 20v and it starts up. Then running I get 43 volts until I touch the...
  8. Replies
    38
    Views
    4,512

    Already did this today. No issues with plugs as...

    Already did this today. No issues with plugs as it did not change anything.
  9. Replies
    38
    Views
    4,512

    Yep, I know how it all works. This is not new to...

    Yep, I know how it all works. This is not new to me. BUT that being said, this is an issue that has not been resolved to looking at everything I can. Hand turning the TPS will send extra fuel into...
  10. Replies
    38
    Views
    4,512

    OK, tested the TPS off the engine. Engine...

    OK, tested the TPS off the engine. Engine respons and will keep running. Once you touch the throttle it dies. Like it is getting too much fuel and floods out. Then it will not start again for a...
  11. Replies
    38
    Views
    4,512

    What should the CPS test out at for ohms? ...

    What should the CPS test out at for ohms?

    LR-503 is still bypassed

    I will try the TPS off the engine and rotate it (when I get it started again).
  12. Replies
    38
    Views
    4,512

    So, any new ideas? I have tested and replaced...

    So, any new ideas? I have tested and replaced almost everything I could for this issue.

    Craft will start and idle but you touch the throttle and it dies. What I have done so far:

    New TPS...
  13. Replies
    38
    Views
    4,512

    Yes, new 91 fuel this year. Same as I run in my...

    Yes, new 91 fuel this year. Same as I run in my boat. Fuel should not be the issue but I could drain it and put in new fuel just to see.
  14. Replies
    38
    Views
    4,512

    Bypassed the LR-503 mod and the craft started up...

    Bypassed the LR-503 mod and the craft started up the same, ran for 30-60 secs and shut off. So the LR-503 should be good. I had the fuel pressure gauge connected and fuel was just over 20# the...
  15. Replies
    38
    Views
    4,512

    Plugs are correct. It idles fine for 30-60 secs...

    Plugs are correct. It idles fine for 30-60 secs then just shuts off.
  16. Replies
    38
    Views
    4,512

    I will jump it tomorrow and see if it runs...

    I will jump it tomorrow and see if it runs correctly. Thanks for the reminder.
  17. Replies
    38
    Views
    4,512

    EMM part # is 4010848a Reverse motor checked...

    EMM part # is 4010848a

    Reverse motor checked good but not operating
    Bilge checks good just blows fuse when handle bar controller is pushed
    Injectors are correct for this EMM and this craft ran...
  18. Replies
    38
    Views
    4,512

    Polaris 2004 Genesis i 1200 Issues

    I have been reading a lot on this forum and finally thought I would jump in with my questions.

    I have a 2004 Genesis i 1200. Bought it last year and it ran great with a few little issues. Put...
Results 1 to 18 of 18