Search

Type: Posts; User: Trooper182

Page 1 of 3 1 2 3

Search: Search took 0.00 seconds.

  1. Replies
    20
    Views
    315

    This last time it took me about 4 hours from...

    This last time it took me about 4 hours from start to finish. I probably could have had it done in 3 but it's hot in my garage so I had to take breaks to cool off lol. Really hardest part for me is...
  2. Replies
    2
    Views
    76

    I've thought about rodent issues but have never...

    I've thought about rodent issues but have never had any issues with them in the past getting into my garage. I may just leave the seats closed and have my wife open them once a week for a few hours...
  3. Replies
    2
    Views
    76

    Storing the skis away

    Well time to put the skis away unfortunately. Got a few good trips out of them. So for storage I have flushed both of the skis, added fuel stabilizer the last trip out and both tanks are almost full,...
  4. Replies
    20
    Views
    315

    Well took everything apart today and verified all...

    Well took everything apart today and verified all the connections are tight and clean. Put it all back together and tried to run the ski. It starts and revs up but on my fuel pressure gauge it is...
  5. Replies
    20
    Views
    315

    Yes correct, there are two blade connectors...

    Yes correct, there are two blade connectors inside the canister. One is brown and one blue with locking tabs on the blade. I let the ski sit overnight not on the battery tender. I wanted to let it...
  6. Replies
    20
    Views
    315

    I will check tomorrow, too dark on the garage...

    I will check tomorrow, too dark on the garage lol. Shouldn't the voltage be dropping across the brown wire when starting? I will also check on the other ski and see what the readings on that one are
  7. Replies
    20
    Views
    315

    Took the skis out today and still having the...

    Took the skis out today and still having the issue. I also took tools with me to see if I could figure it out. My observations is that the issue is only happening after the ski has run for a while....
  8. Replies
    20
    Views
    315

    Ok so checked pin-40 for any signs of corrosion...

    Ok so checked pin-40 for any signs of corrosion and found none. I went ahead and cleaned the connector with QD Electronic Cleaner and let it dry. Reconnect the socket and it fired up fine.
  9. Replies
    20
    Views
    315

    Ok so went to the garage and tried starting the...

    Ok so went to the garage and tried starting the ski this morning and it fired right up. Fuel pressure is at 23 and running like nothing happened. I went ahead and checked the current draw from the...
  10. Replies
    20
    Views
    315

    Yes, bilge pump does run when press the bilge...

    Yes, bilge pump does run when press the bilge button. Tomorrow I will try swapping the EMM and see if it starts
  11. Replies
    20
    Views
    315

    It's just weird that it was running great all...

    It's just weird that it was running great all day, turn it off for 5 min and now no fuel pressure/pump
  12. Replies
    20
    Views
    315

    Yes the fuel pump will only run if I ground it....

    Yes the fuel pump will only run if I ground it. This is off of the ski that I sent the EEM in to be repaired a few weeks ago. The bilge will not run even with the LR-503 connected
  13. Replies
    20
    Views
    315

    04 virage i fuel pump not running

    So new issue. Seems like I fix one issue and a new one pops up. Took the skis to the lake today and rode for 4 hours. Both skis ran great with no issues. The problem started when it was time to go...
  14. Replies
    7
    Views
    212

    Ok so took the fuel pump out and found the issue....

    Ok so took the fuel pump out and found the issue. You were correct, there was buildup of crud around the screen in the filter. Cleaned it off and the ski ran great all day today until I it was time...
  15. Replies
    7
    Views
    212

    When I did the regulator fix I didn't notice any...

    When I did the regulator fix I didn't notice any contaminates in the tank but I know bad fuel was in there, about 2 gallons worth. I will have to pull the pump again and really take a look at the...
  16. Replies
    7
    Views
    212

    Lol sorry, both skis are virage i model's

    Lol sorry, both skis are virage i model's
  17. Replies
    0
    Views
    168

    FS - Parts Polaris Virage txi throttle bodies

    Bought these just to get the TPS off of it. Have no use for them. Asking 70 shipped anywhere in the lower 48 but am open to offers. Will ship to Canada for additional shipping...
  18. Replies
    7
    Views
    212

    Ski cutting out on the water

    Finally got to take both skis out on the water and really test them out. My 04 that just had the EMM repaired was working great other than bogging down. Ran great for about 30 min and then I tried...
  19. Replies
    7
    Views
    143

    Out of curiosity, did you try pulling the spark...

    Out of curiosity, did you try pulling the spark plugs and turning the motor over? You said it may be flooded, if so that could keep the motor from turning over.
  20. Anyone have a spare TPS they would be willing to part with?

    Need a TPS for my 03 Virage i. Verified it was bad by taking the one out of my 04 and putting it on the 03.
  21. Replies
    3
    Views
    143

    I agree. I'm thinking maybe he had a small fuel...

    I agree. I'm thinking maybe he had a small fuel leak somewhere but as of yet the shop has not been able to find one. Seen the videos of people being blown in the air when a bilge explodes. Also see...
  22. Replies
    3
    Views
    143

    Why no bilge blower?

    Ok so I have owned many boats. Everything from bass boats to bayliner. Every boat I have owned that was a I/O had a bilge blower. I ran the blower 5 min before starting, while fueling and anytime we...
  23. Replies
    15
    Views
    288

    Yup I was able to use a app to scan the QR codes....

    Yup I was able to use a app to scan the QR codes. It took a while but it was able to read them and the S/Ns matched. Dropped it in the mail today.
  24. Replies
    15
    Views
    288

    I'm sending the EMM off to lakeside tech tomorrow...

    I'm sending the EMM off to lakeside tech tomorrow to get the EMM matched to the injectors.
  25. Replies
    15
    Views
    288

    Ok think I found the issue. The first two...

    Ok think I found the issue. The first two pictures are the sn on the good running ski. SN showed 1486 on the EEM and what looks to be 1486 on the engine. The other two photos are from the bad running...
Results 1 to 25 of 51
Page 1 of 3 1 2 3