Search

Type: Posts; User: ICURNVS

Page 1 of 3 1 2 3

Search: Search took 0.03 seconds.

  1. Replies
    107
    Views
    3,548

    Progress! But more confusion! i disconnected the...

    Progress! But more confusion! i disconnected the red/white and blue injector connector to test voltage, pushed the start button and instantly got spark, fuel pressure, and voltage in injector...
  2. Replies
    107
    Views
    3,548

    No power to the injectors on the white/red wire...

    No power to the injectors on the white/red wire connected to injectors while cranking. Tested stator voltage while cranking and got ~7Vac on pins 1,12 and 2,11. got ~5Vac on pins 3,10 and 4,9 and...
  3. Replies
    107
    Views
    3,548

    i'll get a measurement from the red/white wire...

    i'll get a measurement from the red/white wire and report back.

    It's weird that the fuel pump doesn't prime/start when attempting to start the engine. is this a clue to be looking at something?
  4. Replies
    107
    Views
    3,548

    I get continuity (0 ohms) on the BLK/Yellow kill...

    I get continuity (0 ohms) on the BLK/Yellow kill switch wire to Ground when I remove the lanyard. With the lanyard in, I don't see any voltage on the BLK/Yellow wire when measured to ground

    I...
  5. Replies
    107
    Views
    3,548

    Tested CPS at 159 ohms. Trying to test lanyard...

    Tested CPS at 159 ohms. Trying to test lanyard kill switch and I'm not sure I'm doing it right. I'm not getting 12v at the connector for the LR module from BLK/yellow wire to ground. Should I be...
  6. Replies
    107
    Views
    3,548

    Perfect, I'll update later today on what I find...

    Perfect, I'll update later today on what I find with the CPS. Thanks guys!
  7. Replies
    107
    Views
    3,548

    Thanks hiperco! Lanyard definitely in, shorted...

    Thanks hiperco! Lanyard definitely in, shorted fuel pump to ground and got 24 psi at the fuel rail. Checked spark and didn't see any spark. Fuel pump doesn't activate when cranking either....
  8. Replies
    107
    Views
    3,548

    Well I'm back at it again. Ski doesn't start,...

    Well I'm back at it again. Ski doesn't start, fuel pump doesn't turn on when attempting to start, no spark at the plugs when turning over. Where should I begin looking? Possible the EMM went bad...
  9. Replies
    107
    Views
    3,548

    Great news everyone! decided to take the...

    Great news everyone! decided to take the afternoon off to hit the lake with the re-routed cooling line since it's 80 degrees and 2mph wind (don't see many days like that in wyoming :roll:) Well after...
  10. Replies
    107
    Views
    3,548

    well at lunch i was able to route the coolant...

    well at lunch i was able to route the coolant line correctly through the stator and EMM. all other cooling lines were correctly installed. going to seal off the water injection nipple to effectively...
  11. Replies
    107
    Views
    3,548

    Lol good point. Not sure I'd trust any prior work...

    Lol good point. Not sure I'd trust any prior work done on this machine now
  12. Replies
    107
    Views
    3,548

    Well nix that idea! i'll look in to doing the...

    Well nix that idea! i'll look in to doing the regulator fix. hopefully maybe it has already been done at some point in the ski's life but i doubt it.
  13. Replies
    107
    Views
    3,548

    Saw that! thank god i don't have to deal with...

    Saw that! thank god i don't have to deal with salt in my neck of the woods! although, riding through channels of tropical water does make my mouth water a little!



    i read a forum post a little...
  14. Replies
    107
    Views
    3,548

    Haha i'm sure it will be. fortunately i'm pretty...

    Haha i'm sure it will be. fortunately i'm pretty patient and since i'm able to do 90% of the work myself, it helps keep the costs down. After a while, it kinda becomes a hobby lol. But for the 30ish...
  15. Replies
    107
    Views
    3,548

    when i tested the fuel pressure prior to getting...

    when i tested the fuel pressure prior to getting the EMM repaired by Lakeside Tech (Amazing service, Can't say enough good things about Lakeside Tech), the fuel pressure was 20psi while cranking....
  16. Replies
    107
    Views
    3,548

    that's the plan. i'm going to run through all...

    that's the plan. i'm going to run through all cooling connections and verify they make sense. i found a different cooling system diagram that makes a little more sense than the one HiPeRco posted....
  17. Replies
    107
    Views
    3,548

    Well my assumptions were correct. the hose that...

    Well my assumptions were correct. the hose that is supposed to feed the stator and then the emm then out the back, was connected to the nipple for the water injection solenoid at the exhaust....
  18. Replies
    107
    Views
    3,548

    Ugg this is definitely not how mine is connected....

    Ugg this is definitely not how mine is connected. Mine has the solenoid plugged in to the bottom brass fitting and the other side of the solenoid heads to the thru-hull exhaust. So it appears the...
  19. Replies
    107
    Views
    3,548

    Something does seem odd about this solenoid and...

    Something does seem odd about this solenoid and how it's connected. There are 2 brass elbows on the front of the stator. One is shown in the picture. The other is near the bottom of the stator. The...
  20. Replies
    107
    Views
    3,548

    Super confused on the water flow through the...

    Super confused on the water flow through the stator. Not sure where the water inlet is on the stator.

    The brass fitting on the top heads to the EMM. A brass fitting on the bottom heads to the...
  21. Replies
    107
    Views
    3,548

    Well I'm not getting water out the disconnected...

    Well I'm not getting water out the disconnected brass fitting shown in the picture. Does water come in to the stator through the solenoid at the bottom shown in the picture?432999432999
  22. Replies
    107
    Views
    3,548

    I removed the hose from the stator that heads to...

    I removed the hose from the stator that heads to the EMM. I was able to freely blow air through the hose and could hear the air coming out the exhaust in the back so there doesn't appear to be a...
  23. Replies
    107
    Views
    3,548

    Pulled the hoses off the EMM and could see...

    Pulled the hoses off the EMM and could see moisture inside the hoses and inside the nipples of the EMM. Anything else to try?
  24. Replies
    107
    Views
    3,548

    New update: got an LED diagnostic tool made to...

    New update: got an LED diagnostic tool made to try read the check engine code. Only one code displayed. CODE 25 EMM Temperature Sensor Above Expected Range.

    Gonna figure out a way to verify the...
  25. Replies
    107
    Views
    3,548

    Not sure if the correct impeller is installed but...

    Not sure if the correct impeller is installed but when I had the jet pump unit off, it looked in great shape.

    Not sure about the water injection solenoid. I'll have to look it up in the manual to...
Results 1 to 25 of 67
Page 1 of 3 1 2 3