Search

Type: Posts; User: wfirst

Search: Search took 0.00 seconds.

  1. Replies
    4
    Views
    397

    got it. just placed the order. The...

    got it. just placed the order.



    The technical term i was looking for was "trim ring", sure is broken though! :lol: it could have possibly happened with the two previous owners but ill never...
  2. Replies
    4
    Views
    397

    Steering nozzle broke off.

    just when i think i have everything buttoned up :roll:... my trim ring that sits within the nozzle decided to break off today, not sure how but it was during a 75mph pull. The metal just completely...
  3. cannot confirm whether or not the functions...

    cannot confirm whether or not the functions worked. I am the second owner, I got it with 2.3 hours. Will look for those wires.
  4. The up and down arrow buttons to pick your...

    The up and down arrow buttons to pick your desired speed? nope, those don’t do anything either.
  5. I have tried all of the above, I've tried many...

    I have tried all of the above, I've tried many different variations of holding the button for different amounts of time, trying it in forward and neutral, idling or 5 mph; absolutely nothing pops up...
  6. View Post

    20’ VX Cruiser no wake mode won’t activate. It’s only got 10 hours on it, what gives? Anyone else ever run into this issue and find the fix?
  7. Replies
    16
    Views
    1,211

    just about every clamp was barely hand tight....

    just about every clamp was barely hand tight. :roll: nice mechanic work.

    just googled those, gonna have to order some. in the meantime I've double hose clamped where i can so i can still get back...
  8. Replies
    16
    Views
    1,211

    View Post

    Sounds like my 17’ just wants to be a PITA then lol. I let my buddy hop on it and forgot to remind him to let off the throttle slowly, of course power loss happens again, thought it would be the same...
  9. Replies
    16
    Views
    1,211

    have no clue what kinda hose clamp it is. The...

    have no clue what kinda hose clamp it is. The mechanics might’ve thrown some new ones on when they took the engine out for the new stator. From 63 to 74.2 mph, I’m stoked it was a simple fix!...
  10. Replies
    16
    Views
    1,211

    well I think I’ve figured it out....

    well I think I’ve figured it out. http://greenhulk.net/forums/attachment.php?attachmentid=476451&stc=1 J pipe was completely disconnected on the inter cooler side.
  11. Replies
    16
    Views
    1,211

    Yes, I literally just picked it up yesterday from...

    Yes, I literally just picked it up yesterday from the jetski mechanic. I am the third owner of this ski, so I’m not quite sure I’ve ever got to experience it’s full potential, I was only able to ride...
  12. Replies
    16
    Views
    1,211

    View Post

    Didn’t think to look at the RPM’s. 91 octane. Brand new spark plugs, oil, stator, and rectifier. My speedometer only reads 0 but the paddle wheel spins freely, hence the use of the iPhone speedo app.
  13. Replies
    16
    Views
    1,211

    View Post

    What’s the usual top speed for a stock 17’ gp1800, 69mph? I was using my iPhone 12 Pro Max with a speedometer app and could only hit 62.9mph on a decently calm ocean this morning, definitely not flat...
  14. Replies
    5
    Views
    559

    Well i thought it was fixed, but I took it out on...

    Well i thought it was fixed, but I took it out on the water and yet again, battery wasn’t charging even with new battery and rectifier. Taking it to a jetski mechanic near me. I’ll post an update...
  15. Replies
    5
    Views
    559

    Yup, the trim worked perfectly out on the water,...

    Yup, the trim worked perfectly out on the water, also will read N and R on the gauge so the computer for sure is there trying to work the missing mechanical pieces I’ve ordered I hope. Thanks for the...
  16. Replies
    4
    Views
    480

    I’m the third owner. Previous owner didn’t seem...

    I’m the third owner. Previous owner didn’t seem to know much about it besides the fact that he was told it had a stage 1 tune. He said the hull was reinforced because he was told to do so but it...
  17. Replies
    5
    Views
    559

    The battery issue was a bad regulator rectifier...

    The battery issue was a bad regulator rectifier like you said.http://greenhulk.net/forums/attachment.php?attachmentid=473374&stc=1 The RiDE stuff on the handlebar is all there.
  18. Replies
    5
    Views
    559

    View Post

    Recently picked up a 17’ GP1800 with 43 hours on it. Started up multiple times before hitting the water, no issues. Ran beautiful for a couple hours and by the time I was pulling it back onto my...
  19. Replies
    4
    Views
    480

    View Post

    Picked up a 17’ Yamaha GP1800 yesterday. Owner said the guy he picked it up from was a racer and removed the reverse bucket on it and lost all the parts. I’m wondering if I order the “jet unit 3”...
Results 1 to 19 of 19