19 Visitor Messages

  1. Hi Steve, trying to remove jet pump from 2001 Ultra 130 di. I believe it is just 4 bolts and 2 from the ride plate. Before I start to pull it, I want to make sure there is nothing else I need to disconnect. Any help is greatly appreciated! Thank you!!
  2. Hi Steve, this is AzRiverRat aka Jerry. I'm the guy who was looking for the geen Kawi vinyl.
    While you're here if you want to get a hold of me you can call or text me at 623-695-7662.
  3. Hi Steve
    Hope it's OK to private message you....

    I swear I saw somewhere that opening a passage on CV carbs makes the vacuum slide more responsive.
    Have you heard of this?
    If so, please guide me to do it if it helps.

    seems like engine is sluggish to respond and I thought this might be good to do.

    thanks
    David
    1100ZXI 1998
  4. I would like to rent your heavy duty pullers you made for the Ultra 150. Can't get the top two studs to break free. My phone number is 5743202265. Thank you.
  5. Sorry my number is 6318484032
  6. Steve hey I just picked up an 99 ultra 150 with 40 hours. Pretty sure the pump bearings went. Can I buy or rent your puller. Let me know. Thankyou.
  7. Thx
  8. Hi Steve
    My friend who is not speaking english ask me to help with his STX1100 from 2003. Display has the corossion on the PCB and is not working. Is there any chance to bypass the display? i read the schematic diagram and in my opinion there is no chance. the big corrion is on IC5 TR8 and LED1 so without detailed schematic it will be too difficult to repair. do you have any knowledge about who can repair it ?
  9. Hey Steve, Its been a while but I still have my 04 Kawasaki STXR and was running great until yesterday. The temp sensor comes on periodically and sends the engine to limp mode. Usually happens around full throttle and after about 5 seconds its right back to normal. There is constant and heavy flow of water out of the pissers even at idle so I was wondering if you had any ideas. The repair shop I go to is really backed up and I was wondering if you had any steps I could take as a guy who's not super mechanically inclined to diagnose the problem.
    Thanks in advance,
    Joe
  10. Hi Steve, came across your ultra 150 jet pump puller. Still renting? I could really use it!

    Call or text me please! 631-879-8200
Showing Visitor Messages 1 to 10 of 19
Page 1 of 2 12 LastLast
Page 1 of 2 12 LastLast
About steve45

Basic Information

About steve45
Biography:
Old Fart. Mechanical Engineer, Pilot (ATP AMEL, COM ASEL, PVT Glider, CFII ASEL), Sales, 40 years experience in oil & gas industry including Exploration & Production, Gas Compression, & Refineries.
Location:
Texas
Skis:
(2) Kawi Ultra 150, Kawi 310X, (2) Kawi LX, Kawi STX-15F, Kawi Jet Mate
Occupation:
RETIRED!

Signature


'15 Kawi Ultra 310X
'99 Kawi Ultra 150 (2)
'10 Kawi Ultra LX, '13 Kawi Ultra LX, '13 Kawi Ultra LX parts 'Ski
'04 Kawi STX 15-F, '06 STX 15-F (2)
'91 Kawi Jet Mate
'97 Yamaha Exciter 220 (Boat)
'99 Yamaha Exciter 270 (Boat)
'78 Nacra 5.2 Catamaran
'05 Windrider WR-10 Trimaran, '05 Windrider WR-16 Trimaran
... and that's just the boats! I'm living proof that you can have too many toys!

Statistics


Total Posts
Total Posts
9,477
Posts Per Day
1.75
Visitor Messages
Total Messages
19
Most Recent Message
09-09-2022 12:45 PM
Total +1
Total +1
412
General Information
Last Activity
Today 08:21 AM
Current Activity
Viewing Forum Personal Watercraft Performance Skis
Join Date
02-12-2008

1 Friend

Showing Friends 1 to 1 of 1