13 Visitor Messages

  1. Thx
  2. Hi Steve
    My friend who is not speaking english ask me to help with his STX1100 from 2003. Display has the corossion on the PCB and is not working. Is there any chance to bypass the display? i read the schematic diagram and in my opinion there is no chance. the big corrion is on IC5 TR8 and LED1 so without detailed schematic it will be too difficult to repair. do you have any knowledge about who can repair it ?
  3. Hey Steve, Its been a while but I still have my 04 Kawasaki STXR and was running great until yesterday. The temp sensor comes on periodically and sends the engine to limp mode. Usually happens around full throttle and after about 5 seconds its right back to normal. There is constant and heavy flow of water out of the pissers even at idle so I was wondering if you had any ideas. The repair shop I go to is really backed up and I was wondering if you had any steps I could take as a guy who's not super mechanically inclined to diagnose the problem.
    Thanks in advance,
    Joe
  4. Hi Steve, came across your ultra 150 jet pump puller. Still renting? I could really use it!

    Call or text me please! 631-879-8200
  5. Sorry, I didn't notice that I had a message. It's been several years since I had a 150 pump apart and I'll have to refer to the service manual. I'm traveling this week and don't have my manual available, so it will be this weekend before I can look it up. Best to just ask the forum as there are a number of people there that can help you.
  6. Steve,

    I am rebuilding the pump on a Ultra 150. I've got it apart except getting the bearing out of the cone, any recommendations?
  7. Hello Steve - If you have a couple mins, please give me a call. I am really struggling with this 15F Kawie jet ski. I changed the ECU, I am now getting spark but I still cant get it to fire even when I add gas down the cylinders. Thanks Scott 262-719-4047
  8. Hey Steve you seem very knowledgeable. I have a 1100 stx di , hesitating at WOT , spark arrestor had oil in it , a film of oil on the grates. Cleaned the oil out of all the spark arrestor and grates. Ran perfect first time out. Second time , back to hesitating and oil in the spark arrestor again. Why would I be getting oil in the spark arrestor ? Any help or suggestions would be appreciated 
  9. Hey Steve you seem very knowledgeable. I have a 1100 stx di , hesitating at WOT , spark arrestor had oil in it , a film of oil on the grates. Cleaned the oil out of all the spark arrestor and grates. Ran perfect first time out. Second time , back to hesitating and oil in the spark arrestor again. Why would I be getting oil in the spark arrestor ? Any help or suggestions would be appreciated ��
  10. I tried to send a pm, but it seems like it did not work. I want to rent your pullers. Can you pm me or email geneserafim1@yahoo.com?
    Gene
Showing Visitor Messages 1 to 10 of 13
Page 1 of 2 12 LastLast
Page 1 of 2 12 LastLast
About steve45

Basic Information

About steve45
Location:
Texas
Skis:
(2) Kawi Ultra 150, Kawi 310X, (2) Kawi LX, Kawi STX-15F, Kawi Jet Mate
Occupation:
Sales

Signature


'15 Kawi Ultra 310X
'99 Kawi Ultra 150 (2)
'10 Kawi Ultra LX, '13 Kawi Ultra LX, '13 Kawi Ultra LX parts 'Ski
'04 Kawi STX 15-F, '06 STX 15-F (2)
'91 Kawi Jet Mate
'97 Yamaha Exciter 220 (Boat)
'99 Yamaha Exciter 270 (Boat)
'78 Nacra 5.2 Catamaran
'05 Windrider WR-10 Trimaran, '05 Windrider WR-16 Trimaran
... and that's just the boats! I'm living proof that you can have too many toys!

Statistics


Total Posts
Total Posts
9,109
Posts Per Day
1.73
Visitor Messages
Total Messages
13
Most Recent Message
06-26-2022 04:58 AM
Total +1
Total +1
381
General Information
Last Activity
Today 08:51 AM
Join Date
02-12-2008

1 Friend

Showing Friends 1 to 1 of 1